1. MacandBerry's Avatar
    When I plug my tour in is doesn't mount the sd card or bb memory so I can't add or remove things from the sd card. On my storm it worked first time. My memory settings are set to mass storage on and connect on plug in. Have tried resetting mem settings with no luck. I do get and insufficient usb charge when plugged in to my laptop. Not sure if this is a contributing factor.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-14-09 06:17 PM
  2. lionheart123's Avatar
    I would suggest fully charging your Tour, and setting Mass Storage Mode to off. If it's still not working you may need to check your device manager for conflicts. However, I'm on a Vista machine, and I have no idea where you would go for that in a Mac. Hope this helps a little bit.
    08-14-09 06:37 PM
  3. tgaskill's Avatar
    What Mac laptop do you own, and what OS are you running? I have a G4 Powerbook running 10.5.7 (installing 10.5.8 as I type this) and it works just fine.
    Maybe with a few more specs about your machine I can be of more assistance.
    08-14-09 06:46 PM
  4. sinfony's Avatar
    mine works just fine on my mac. use a pc? lol jk

    what hardware / os are you running
    08-14-09 07:23 PM
  5. GM_blackberry's Avatar
    It worked fine on my Mac. I had charged it up first, if that makes a difference. I had added a 16 GB card, so I loaded lots of my music and a bunch of photos.
    08-14-09 09:36 PM
  6. showstopr30's Avatar
    I personally had to update to 10.5.8 before it finally saw my Tour
    08-14-09 09:40 PM
  7. xwera43's Avatar
    This is my second one, the first was fine on 10.5.7 and this is fine on 10.5.8. In Options/Memory set it to:


    If that doesn't work try re-formatting your SD card.

    Good luck!


    Posted from my CrackBerry at wapforums.crackberry.com
    08-14-09 10:51 PM
  8. brinky's Avatar
    Can your tour actually see the memory card? Mine tends to forget it is in there and I have to do a battery pull to get it back. If the tour doesn't know about the SD card, neither will the mac.
    08-14-09 11:13 PM
  9. vomNoble's Avatar
    Have a mac. Just got a tour less than a week ago.

    Put the cd in my mac that came with the tour figuring it would be the first step to figuring things out. My mac won't read the cd. So I haven't plugged the phone into it for fear of screwing things up somehow.

    I've played with my tour (which is my first blackberry, by the way!) and figured some stuff out on my own. (although THIS site has been my BEST learning experience hands down!) But I haven't put any music or pics or anything 'personal' including new apps that I am DYING to have!

    If ya feel for me..... your knowlege greatly appreciated!
    08-15-09 05:08 AM
  10. MacandBerry's Avatar
    Its a G4 running 10.4.notsure. My settings are on none on on yes. Can't really afford 10.5 yet. Just waiting till I can get a ibook. But not any time soon

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 06:36 AM
  11. tgaskill's Avatar
    MacandBerry - I'm not sure what the problem is. We have a number of Macs (everything from Mac Minis running 10.3.XX, G4 towers running 10.4.XX and the latest iMac running 10.5.8) and they all worked just fine. It loaded up and placed the normal removable media icon on the desktop. Just for kicks and grins, you might try setting it to prompt you for Mass Storage Mode and see what happens.
    It could be your tower isn't pushing enough power through the USB port. We had an older tower at work that wouldn't power a card reader and we had to install a USB 2.0 PCI expansion card.
    Sorry I couldn't be more help, but I just couldn't reproduce the problem.
    08-15-09 08:08 PM
  12. craigy2009's Avatar
    I had this same problem initially. I have a 20" iMac running OS X 10.4 (Tiger). The problem turned out to be settings. Here's what worked for me. (I acknowledge that you have done the first two things. Also, it may be possible that if you switch to another USB port (if there is one) that you might get more power to get a connection. The USB ports on the keyboard often don't supply enough juice, so I have to use one at the back of the computer.)

    - Start Options and scroll down to and click on Memory.
    - Set the Mass Storage Mode Support: to On. (I left Auto Enable Mass Storage Mode When Connected: at Prompt.)
    - Press the Blackberry button, and click on Save.
    - Restart Options. When you click on the Blackberry button you should now see the option Enable USB Mass Storage. Click on that, and a removable disk icon named NO NAME should appear on screen within a few seconds.

    I don't think you can get away with not having Mass Storage mode set to on. If you did the above as I did, when you connect your Tour to your Mac you should get the prompt "Do you want to turn on Mass Storage Mode? You might not be able to access some media files in this mode." followed by Yes and No buttons. If you do not want to see this prompt, set the Auto Enable Mass Storage Mode When Connected: to Yes, then save that setting.

    I hope this helps.
    08-15-09 09:25 PM
  13. festiva93's Avatar
    If you do a search, there is a great fix for this. I had the same problem and posted in that forum. I apologize that I don't have the direct link... But if you search my posts it's in there. There's a file to delete and some new drivers to download. It worked like a charm. There are step by step instructions. Good luck!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 09:51 PM