1. ericjay's Avatar
    I have had an 8130 for a while now, and with my iBook (running Tiger), I was always able to connect it via USB and mount the SD card in Mass Storage Mode. This was my primary means of getting music to my SD card, and getting photos from my BB to my computer.

    I never really worried about syncing, since I sync the Calendar OTA, and don't keep contacts on my computer.

    I recently upgraded to a new MacBook (running Leopard). When I connect my 8130 to the machine via USB, I first get the error message that USB charging current is not sufficient. Then, am prompted to enter my password to activate Mass Storage Mode (which I got on my iBook). However, once I enter my password, the BB screen goes dark, and the LED goes solid red. This stays in this state until I disconnect the USB cable, at which point the BB goes through with what appears to be a hard reset.

    I went back to my iBook and was able to mount the SD card just fine.

    Has anyone had this problem? Any suggestions?
    09-09-08 12:04 AM
  2. xholmezx78's Avatar
    You need to update the drivers in Leopard for the Curve and Pearl devices. The USB drivers in MacOS X Leopard are older then what is required for the newer blackberries. Simply go to Blackberry.com, downloads and select the Mac software. Download and install the PocketMac sync software and the latest USB driver update. This will fix your issues.
    09-09-08 03:01 PM
  3. ericjay's Avatar
    Thanks for the suggestion. I downloaded PocketMac, but couldn't find the driver update you mentioned. According to this thread on the BlackBerry.com Support Forums, DriverUpdate.dmg is no longer necessary with PocketMac 4.1.

    Anyway, I downloaded a file labeled "4.1.25", but when I install it, the About window reads "Version 1.2 (1.4)." When I connect the BB, I now get this error:

    The system extension "/System/Library/Extensions/BlackberryUSBDev.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update.
    Of course, if I activate Mass Storage mode, I still get the behavior listed in my original post: the BB reboots.

    If I watch Disk Utility, I see the BB and it's loaded media card appear as soon as I activate Mass Storage... but both disappear as soon as the device resets.
    09-09-08 04:43 PM
  4. Delegator's Avatar
    Same problem here. Tried the newest PocketMac, and also Missing Sync. Downloaded the latest driver from RIM. No joy. I guess it's off to tech support unless somebody has come up with a solution of which I'm not yet aware.
    12-01-08 11:49 AM
  5. Dean Starink's Avatar
    I also have the new MacBook and BB Pearl 8130.

    I download the pocket Mac and the drivers from the BB site. I was able to do a complete synch once, now I can't synch. It seems that something in the contacts causes the synch to just idle indefinitely.

    If I turn the contact synch off it synchonizes everything fine.

    Does anyone have a solution to get the
    12-01-08 12:28 PM
  6. Delegator's Avatar
    I downloaded the new software and drivers, installed (and rebooted) installed the drivers (and rebooted) and still have the same problem. :-(

    The Pearl shuts down, reboots, gets a beach ball for a while, the V screen, then shuts down again, and so on.
    12-01-08 05:31 PM
  7. Delegator's Avatar
    Found this thread at the BlackBerry forums, which says that PocketMac has problems with the new MacBooks, and that the issue is known to both RIM and PocketMac:

    BlackBerry Support Community Forums - Pocket Mac 4.1 does not work with new alluminum macbooks confrimed with RIM (Pocketmac support) - BlackBerry® for Mac - BlackBerry Support Community Forums

    So, I guess I go back to syncing with Windows via Bootcamp or Parallels. Bleh.
    12-01-08 06:52 PM