1. Protagonist's Avatar
    After having this problem myself I noted a number of people complaining about it in the Beta OS forum. Hopefully we can share our experiences here and come up with a solution that lets us Mac users update our software while we wait for a real solution from RIM in the form of a mac version of desktop manager.

    My issue: When installing a new OS ( on my Rogers branded 8900 the install will fail with a 'fatal error' after the uploading RAM image step completes.

    My setup:

    Macbook Air 1.8/128 SSD with OS 10.5.6
    VMWare Fusion 2.01 with Windows XP Pro
    Desktop Manager v4.5, 4.6, 4.7.
    Directly connected to USB, no hub involved.

    In the past I have had no issue updating software on Blackberry 8700c, 8310 and 9000 (rogers) models under DM 4.6. The last time I did so was about 1 month ago.

    I have seen others report issues updating the Bold to OS on macs running both parallels and VMWare.

    Some of the other posts that led me to make this thread:


    i cant seem to upgrade running parallels/windows xp on my iMac...

    everything seems to be fine, i installed the .217 version after i deleted the .216 off the pc...i deleted the vendor.xml and i turned bb desktop manager on, plugged my bold in and when i went to application loader, it saw that I had .217 available so i check mark it
    then i click next and it goes to update summary and says i dont need any updates at this time...wtf??

    when i go to common files/rim/apploader and click the loader .exe in there itll back up everything and when it goes to the update ROM part of it after the backing up...my phone will just restart and then the loader will say ERROR....

    is there a problem with the USB in parallels or something or im not understanding..?
    ok so i installed 4.6 on my parallels/mac instead of 4.7 DM and still no luck! this time i got past the update screen and go to the "Connecting to ROM" when my blackberry would restart, red LED on, then off and white screen with hour glass comes up...then the windows xp makes that sound like a USB is connected, and then the phone reboots again and same thing, after the third time the DM says there was a fatal error

    ya still having problems with parallels...idk if the xp/mac are communicating and disrupting the process of the phone, seems like the only explanation i can come up with since i just updated from .167 to .216 over a Dell the other day flawlessly....idk how to make it stop communicating tho because when i connect the BB i choose to run it in parallels only not mac, should i make parallels sit in full screen or what?


    I don't use Parallels, I use VMware Fusion, but I am having the same problems recently... I used to do all of my device OS maintenance on my Mac, and all of a sudden I'm having a ton of difficulty. I have to run the OS installation exe several times for it to stick, somehow all the files don't make their way onto the virtual computer. Then when I attempt to upgrade or downgrade, it either fails or bricks the device. The last 3 times I've attempted to work on my BB from my Mac I've ended up having to 'fix' it on my PC at work.
    I don't think its a RIM issue, I think it was one of the Mac OS system updates that screwed up how virtual machines funtion. I have been using the same blackberry with the same DM version on the same virtual machine on the same Mac for months. It worked worked worked - then failed. The only change was Mac OS updates. I don't even run windows updates in the VM.


    Ok, so I have an iMac as well running Tiger and have had no problems upgrading the curve using VMware Fusion (the Parallels alternative). I do know that sometimes if the window isn't focused when the device is plugged in, it will allow Mac OS access to the device. In other words, if you have a usb device running in Parallels and minimize the windows, then unplug it and plug it back in, it assumes your using the Mac OS and let's the mac control it. Otherwise, everything you would plug in would go straight to windows and would cause problems; likewise, you would likely get all sorts of data corruption and errors if both OSes were accessing the devices at the same time.

    That being said, maybe the update software is reconnecting the device -- are you doing other things on the Mac OS? or is parallels the selected window and such?

    Just a thought. Let us know if you make progress
    .217 went on fine as an upgrade under VMware Fusion on my Mac with 10.5.6.

    Memory is sitting at 50.5mb's after 4 hours and I haven't had any crashes either.

    Last edited by bryanharig; 01-07-09 at 10:33 AM.
    01-07-09 10:30 AM
  2. xxfire's Avatar
    0 issues here..
    XP Pro
    VM Fusion
    MacBook Pro
    01-07-09 01:13 PM
  3. xxfire's Avatar
    I manually put in my OS updates on my Storm. I didnt' ask it.. I just installed .85 I think since it's not a "official" release it wont say it's needed maybe?
    01-07-09 01:14 PM
  4. nitu's Avatar
    Vmware 2.0 under macbook here, 0 problems so far

    Posted from my CrackBerry at wapforums.crackberry.com
    01-07-09 04:39 PM
  5. alt3r77's Avatar
    Hi, I have a major problem, every time during uploader RAM image, my blackberry 8900 just stay for almost an hour.
    I use DM 4.6 and my blackberry 8900 OS 101, I want to upgrade to 114. I did delete the vendor. but it still didn't work out. is there someone out there who can help me to solve this problems? I've been trying to upgrading for this 2 days. Thank's
    01-16-09 04:31 AM