1. SethDove's Avatar
    When I first connected my Z30 it installed Blackberry Link automatically. But when I tried to start the program after it installed, it gave an error that it does not work with my version of OS X (10.6.8, Snow Leopard). Any suggestions on what I should do? Seems as if older versions of Blackberry Desktop Software only works for BB devices before 10. I have no way to access the internal memory of the phone via a Mac, and this is very frustrating. The Playbook never gave me any trouble.
    11-26-13 07:32 AM
  2. sevendev's Avatar
    Hello again.
    After loosing another day of my life on this, I have just come across this on the Blackberry Knowledge Base.

    KB35354-Unable to install BlackBerry Link version 1.1.1 or later on Mac OS X 10.6 or earlier

    well, rather , the lack of support....forum, knowledge base.

    If that had been CLEARLY stated in the system requirements, then
    I would never have got this phone for development purposes as its not currently viable.
    pity.
    It may well be going back

    Hang on..... but

    .... this says I meet (exceed) minimum system requirements.

    http://docs.blackberry.com/en/smartp...9422165186.jsp

    ok, what gives?
    Advice?
  3. jaydee5799's Avatar
    Hi and welcome.
    Have you tried downloading the software from here?
    BlackBerry Link - BlackBerry 10 Smartphone to Computer Sync - US
    I have this software on my MacBook Pro and I am able to manage my device ok.
    11-26-13 07:42 AM
  4. rally5464's Avatar
    I would install Mavericks OS update, it is free. I did on my mac book and have no issues with connectivity between my BlackBerry Z30 and computer.


    Posted via CB10
    11-26-13 07:43 AM
  5. SethDove's Avatar
    @jaydee Yes, that software ware is what the phone installed. And it doesn't work.

    Posted via CB10
    11-26-13 08:21 AM
  6. SethDove's Avatar
    Have to say I'm quite disappointed in this. Part of the reason I've avoided iOS is its reliance on iTunes. Guess I'll have to deal.

    Posted via CB10
    11-26-13 06:25 PM
  7. Man@Arms's Avatar
    Try some basic troubleshooting routes: disconnect phone then reboot, reconnect and test out. If that doesn't work disconnect phone again, uninstall Link, download from BlackBerry Link - BlackBerry 10 Smartphone to Computer Sync - US and install.

    *Disregard I realized Link requires Mac OS 10.7 or later
    11-26-13 06:35 PM
  8. rally5464's Avatar
    Yeah, and Snow Leopard ends at 10.6.8. Jump to Mountain lion (~$30 cost) or Mavericks (free). I had Snow Leopard for the longest time until I got the Z30 and needed to install the new OS.
    11-27-13 07:58 AM
  9. sevendev's Avatar
    Hello there, I had the same issue with the z10.
    Ive posted a possible explanation here
    http://forums.crackberry.com/blackbe...4/#post9619133
    with link to older version of LINK.

    Personally, I have a highly set up, customised installation of Snow Leopard, for development, expensive software, custom configs and also run legacy software via Rosetta stone.
    So, there is NO compulsion to update my entire computers OS in order to get my newest toy to play with it and loose a lot of functionality.
    it would just have been really really nice if
    Link v1.1.1.35
    STILL worked for Snow Leopard
    AFTER
    it had been upgraded to v 1.1.1.39 ... or a link to the older version was maintained OR... it informed you that if you installed it,
    goodbye link functionality

    so try that older one and if anyone has a direct link to v.1.1.1.35 please post so that the likes of myself dont have to destroy our entire virtual world/working environment, just to be able to sync our contacts!
    madness.

    cheers
    11-27-13 09:51 AM
  10. sevendev's Avatar
    Hello again.
    After loosing another day of my life on this, I have just come across this on the Blackberry Knowledge Base.

    KB35354-Unable to install BlackBerry Link version 1.1.1 or later on Mac OS X 10.6 or earlier

    well, rather , the lack of support....forum, knowledge base.

    If that had been CLEARLY stated in the system requirements, then
    I would never have got this phone for development purposes as its not currently viable.
    pity.
    It may well be going back

    Hang on..... but

    .... this says I meet (exceed) minimum system requirements.

    http://docs.blackberry.com/en/smartp...9422165186.jsp

    ok, what gives?
    Advice?
    Last edited by sevendev; 11-27-13 at 05:02 PM.
    11-27-13 01:26 PM
  11. SethDove's Avatar
    Thanks for the tip. I managed to find a link to download v1.1.1.35, per your suggestion. And while it does at least allow me to access the phone's internal memory (big plus, and all I really need), I am not sure that it syncs up. The file is hosted on a Vietnamese file share site, so perhaps sketchy. I bit the bullet and installed (right after doing a full back up). Seems fine so far. If you dare.
    11-28-13 01:05 AM
  12. PHughes's Avatar
    I had a Z10 a few months ago and it was stolen. I was able to use Link with Snow Leopard then. I just got another and got the same error as you. I bit the bullet and upgraded to Mavericks, for free. That was nice. You can upgrade directly from Snow Leopard. I was happy to see the new version of BB Link allowed the syncing of the contacts and calendar without using the cloud, it is direct from computer to Z10.

    As for music and such, I still drag and drop, it is much easier.
    12-03-13 07:17 PM
  13. derwissenschaftler's Avatar
    That's strange... I am using a Z10 with BlackBerry Link on snow leopard. my mac book is the white mid-2008 model. I have the first version of link and never updated it cause it served me just fine. Perhaps you can go to check out a website that has older versions of software for Mac. It's something like old mac software or something like that. Can't remember it of the top of my head. Perhaps you can download the earlier versions of BlackBerry link

    Posted via Crack-friggin-berry Z10
    12-24-13 07:34 AM
  14. MarteeNL's Avatar
    @derwissenschaftler

    Can you tell me wich version that is? and do you still have that Blackberry Link installer?
    I don't want to upgrade Snow Leopard for BlackBerry Link only..
    08-07-14 05:04 AM
  15. eSport's Avatar
    When I first connected my Z30 it installed Blackberry Link automatically. But when I tried to start the program after it installed, it gave an error that it does not work with my version of OS X (10.6.8, Snow Leopard). Any suggestions on what I should do? Seems as if older versions of Blackberry Desktop Software only works for BB devices before 10. I have no way to access the internal memory of the phone via a Mac, and this is very frustrating. The Playbook never gave me any trouble.
    my bb10 device (q10) is running, according to carrier - optus
    software release
    10.2.1.3062
    os version
    10.2.1.3442

    when i plugged into my macbook pro as with you was not compatible.

    macbook pro
    mac os snow leopard v10.6.8
    itunes v11.4 (18)
    blackberry link v1.1.1 (build 33)

    * i searched here as well as exhaustive searching of google and finally tracked down v1.1.1 (build 33)
    12-23-14 06:45 PM

Similar Threads

  1. Does android VPN apps work on bb10 ?!
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 03-14-15, 01:30 AM
  2. Passport is a device so good that many don't believe it's a BlackBerry
    By IndianTiwari in forum General BlackBerry Discussion
    Replies: 37
    Last Post: 10-11-14, 03:12 PM
  3. Replies: 1
    Last Post: 09-29-14, 08:17 AM
  4. How do I get the MEP code for the BlackBerry 9530?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-29-14, 07:57 AM
  5. Will Passport work with my Koodo Sim card
    By pelletizer in forum Ask a Question
    Replies: 1
    Last Post: 09-29-14, 06:51 AM
LINK TO POST COPIED TO CLIPBOARD