1. Batter Pudding's Avatar
    I was helping a friend yesterday with her Macbook pro and Blackberry curve.

    I tried to install the Desktop software from the Blackberry website. On the download page it says you need "Mac OS X v10.5.8 and above". My friend has v10.5.8. Trouble is, when you run the installer, it asks for v10.6

    Does anyone know where I can find an older release of the Desktop software so I can install it on a Mac with OS X v10.5.8?

    Edit: Argh - duff typo in the title of this post. I can't work out how to delete the thread or edit that title now....
    08-01-12 06:03 AM
  2. Batter Pudding's Avatar
    Okay. I guess that are not many Apple users out there then as there has only been 153 views.

    Simpler question - I need to download "BlackBerry Desktop Software - 2.3.1" for Mac. I have found the manuals on the blackberry.co.uk website, but still can't locate links to older software.

    In those manuals \ change notes it is clear that they have only just dropped support for pre v10.6 Macs. So I just need a linky to the previous version of the Blackberry software.

    Any clues?
    08-05-12 09:24 AM
  3. bungaboy's Avatar
    My daughter has the same problem. Can't find where to d/l DM for Mac OS 10.5.8.
    08-15-12 12:44 PM
  4. Batter Pudding's Avatar
    If I ever find a way to solve this, I'll post back in this thread. Even if I end up having to post something to Sendspace to host it.

    What is frustrating is I can't even use an old one from a CD as it would probably just upgrade itself to this latest one.


    Is this the normal world for Apple users? This seems rather early to abandon an "old" OS.


    There is also a noticeable lack of Apple Mac owners on this forum, either that or they all have nice new Macs. My mate doesn't have the cash to keep up with the upgrade game.
    08-15-12 12:53 PM
  5. bungaboy's Avatar
    Well I ended up buying Snow Leopard 10.6.3 from Apple and having it shipped to my daughter. She will then have to upgrade her Mac then install the new BB DM.

    I don't like this Apple ecoterrorismsystem one bit. LoL
    08-15-12 03:41 PM
  6. dpotslinger's Avatar
    I have a macbook from 2008 with OS 10.5.8 on. I recently tried to sync my devices but when it didn't work I deleted DM, then went to BB website do download it again. Unfortunately they have no support whatsoever for "older" OS, confirmed by @BlackberryHelp on Twitter. Very Frustrating. Have you had any luck finding an older version?
    10-16-12 04:38 PM
  7. dpotslinger's Avatar
    Hi I don't know if you are still looking for older Desktop software as you posted in August, but I found this: Download BlackBerry Desktop Manager (Mac)
    10-16-12 04:56 PM
  8. Batter Pudding's Avatar
    Nice find. Downloading now, but I won't see my friend for a few days. Do you know which version of the Desktop Software this is? Or which Mac OS it was built for?

    Thanks for the link.

    (I had given up to be honest and just bought a card reader to get at the photos on the phone...)
    10-17-12 04:52 AM
LINK TO POST COPIED TO CLIPBOARD