1. boxofrain's Avatar
    Hi there. I searched for an answer to no avail. I apologize in advance if this has been covered.

    The setup:

    Three Gmail Accounts (IMAP)
    Blackberry Curve (My very first BB, bought this week!)
    Apple Mail to access the Gmail accounts
    Gmail accounts are set up via Blackberry BIS and not with Gmail's BB app.
    Edit: Verizon Service


    The problem:

    When I have my Mac with Apple Mail running (a majority of the time) mail will only be delivered to my computer and not my blackberry.

    If Apple Mail is not running email will be delivered to both my BB and Apple Mail.

    I would like for it to be delivered to both when I'm running apple mail but can't seem to pinpoint the problem.

    Any suggestions for this BB newb?

    Thanks!
    Last edited by boxofrain; 07-05-08 at 04:59 PM.
    07-05-08 03:03 PM
  2. zach.harding's Avatar
    Hello. I'm a mac user but I do not use mail, so I'm not quite sure how much help I can be, but I will try! A thought that crossed my mind is that possibly apple mail is dominating all of gmails imap time? I mean that the imap syncing between AM and gmail prevents the BIS and gmail from ever getting a chance to imap sync. Just a thought, sorry I don't have a definite solution.

    Other things you can try to test this out would be to have your am only grab 2 of your gmails and see if the 3rd gets through to your bb. Or try forwarding everything into one gmail account to see if that changes anything?

    Edit: also it is probably confusing for all things involved if everything is trying to use 993 to imap? Just some thoughts

    Posted from my CrackBerry at wapforums.crackberry.com
    07-05-08 03:18 PM
  3. boxofrain's Avatar
    Hello. I'm a mac user but I do not use mail, so I'm not quite sure how much help I can be, but I will try! A thought that crossed my mind is that possibly apple mail is dominating all of gmails imap time? I mean that the imap syncing between AM and gmail prevents the BIS and gmail from ever getting a chance to imap sync. Just a thought, sorry I don't have a definite solution.
    It is somehow dominating the mail. I'll probably turn off the AM auto fetch and manually load the mail via "get mail" until I get a better fix. Thanks for the brainstorm.


    Other things you can try to test this out would be to have your am only grab 2 of your gmails and see if the 3rd gets through to your bb. Or try forwarding everything into one gmail account to see if that changes anything?
    Not sure if the auto-grab is "all accounts or nothing" I'll have to take a quick look.

    Edit: also it is probably confusing for all things involved if everything is trying to use 993 to imap? Just some thoughts
    See..this is where I'm in over my head. I really know nothing about ports. This I know. All three accounts on AM go through port 995. Two accounts on my BB use 993 and another uses 995. I don't know what to make of that, if anything

    Perhaps I have the wrong expectations from IMAP. I have no experience with it. I was under the assumption that anything I do on one client gets mirrored in the other. Sent emails and everything! (But that's part II of my problems: to be solved after this one. )

    Either way...thanks for your response and ideas.
    07-05-08 04:09 PM
  4. brinky's Avatar
    Are you sure apple mail is setup for imap for your gmail account and not pop? If it is pop apple mail might be pulling the mail off gmail before the bb has a chance to check it.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-05-08 05:57 PM
  5. boxofrain's Avatar
    Are you sure apple mail is setup for imap for your gmail account and not pop? If it is pop apple mail might be pulling the mail off gmail before the bb has a chance to check it.

    Posted from my CrackBerry at wapforums.crackberry.com
    Good point. The accounts were originally set up in AM as POP. When I switched to IMAP I went into each account and changed the incoming mail server to "imap.gmail.com" The account description is still POP. Perhaps I should delete an account and start from scratch.
    07-05-08 06:16 PM
  6. brinky's Avatar
    That might not help, but POP was the only thing I could think of. Maybe in google mail setting set pop to off?
    07-05-08 06:35 PM
  7. boxofrain's Avatar
    That might not help, but POP was the only thing I could think of. Maybe in google mail setting set pop to off?
    You nailed it! Even though I changed the incoming server in apple mail, it still treated it like pop. As I mentioned before I don't know the behavior of IMAP. I thought it was normal for AM to fetch the IMAP mail much like POP. When I deleted the one account and set it up as IMAP from scratch AM behaved much differently. It wouldn't go out and fetch or grab the mail...it would just appear (much like my old corporate mail) My blackberry soon had the same mail. (Bit of a lag in the servers, though.) Thanks so much for all your help guys!
    07-05-08 07:36 PM
  8. brinky's Avatar
    Glad you got it working. IMO POP is a miserable protocol that should be banned forever. I think it is about the only original protocol still being used. I don't hear about gopher or archie any more. POP should join them

    Posted from my CrackBerry at wapforums.crackberry.com
    07-05-08 07:45 PM
  9. boxofrain's Avatar
    Hey. First post from my BB! I still have a lot to learn, but at least I got the mail working properly. Thanks again for your help.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-05-08 08:03 PM
LINK TO POST COPIED TO CLIPBOARD