1. graffixnyc's Avatar
    Ok, A few of us on here have had issues with outgoing sms messages staying pending. there was a fix that was listed (see below)

    [FIX] SMS Not Sending On OS

    Figured out how to fix the SMS Not Sending Problem

    Note: Not everyone may have this problem and probably only t-mobile customers are having it I dont know.


    Ok so here are the steps that I performed in order to fix the SMS Not sending problem. (I ran multiple tests and this was the only way i fixed it)

    Steps:

    Goto: Settings/Options/Advanced Options/ Host Routing Table and select to register

    Turn off Network Connections after it registered

    Now Hold alt and type l g l g ( Hold Alt + Tap L,G,L,G )

    Now select menu and clear the logs

    Final Step Do a Quick Pull (Let it Last atleast 30 Seconds to clear some flash memory)

    After Re-boot:

    Let the Device connect to the network leave it for about 30 seconds aswell then go ahead and start texting again.
    __________________________________________________ _______


    Ok now the above works, dont get me wrong, but it's a hassle. Everytime you reboot your phone you have to do this... so here is what I discovered tonight

    Tonight I got a SIM rejected message on my phone, after a reboot I got SIM not allowed. I read up and it seems that if your sim card craps out or gets fried for some reason you will get this message. luckily I had another new sim card. I called to activate it. I rebooted my phone and was thinking I would have to apply this fix again since I had to every time I rebooted my phone. but no matter how many times I rebooted my outgoing sms messages sent perfectly fine.

    So since it was a new sim card I enabled SIM PIN security because I had that set on my old sim so when the phone boots up it asks you for the SIM PIN. When I set the sim pin and enabled it on the new sim card I rebooted the phone and guess what? My outgoing messages stayed pending again!!!! So I disabled it rebooted and then they started working and going through.... rebooted 3 times and they were sending fine... so I'm 100% sure that those of us that are having outgoing sms messages staying in pending prob have their sim pin security enabled. For some reason having this enabled is doing something that's not allowing outgoing sms messages to go through. Why this is happening I have no clue but I asked vic_machu19 who was also having this issue if he had sim pin security enabled and he did! I told him to disable it and reboot the phone and send a sms and see if it went through or stayed in pending, it worked.. he rebooted twice sent a SMS and it went through.. So I would bet that 100% of the people that are having the problem with outgoing SMS texts staying pending have SIM secuirty enabled!
    10-30-09 04:39 AM
  2. Phill_UK's Avatar
    You could have kept this thread down to a simple one liner... 'Don't Enable SIM Security'

    Everything else you mentioned has nothing to do with SMS sending, especially deleting the event log

    Glad it worked for you anyway

    Posted from my CrackBerry at wapforums.crackberry.com
    10-30-09 05:55 AM
  3. graffixnyc's Avatar
    You could have kept this thread down to a simple one liner... 'Don't Enable SIM Security'

    Everything else you mentioned has nothing to do with SMS sending, especially deleting the event log

    Glad it worked for you anyway

    Posted from my CrackBerry at wapforums.crackberry.com
    The first part of it with the event log was a fix posted by someone else. While it did work, you would have to do those steps every time the phone rebooted otherwise the SMS messages would stay in a pending state.
    It was just by luck (bad luck since my old sim fried out) that I figured out it was enabling the sim security. Sorry for the long post but this problem was driving me nuts. even the first fix having to do it every time the phone rebooted drove me nuts too. So when I found out what the problem was I got excited hahah
    10-30-09 06:05 AM
  4. bfunknasty's Avatar
    Maybe I'm just dumb but how do u disable sim security?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-30-09 07:45 AM
  5. graffixnyc's Avatar
    Maybe I'm just dumb but how do u disable sim security?

    Posted from my CrackBerry at wapforums.crackberry.com
    go to Options -> Advanced Options -> Sim Card then it the menu button and there will be an option there "Disable Security"
    10-30-09 11:58 AM
  6. vic_machu19's Avatar
    lol u posted at 4 am dude, ur an addict.... im joining bb addicts lol
    10-30-09 12:49 PM
LINK TO POST COPIED TO CLIPBOARD