1. FuzzyFish's Avatar
    Hi everyone, I'm cross posting this from the Bell/Virgin board.

    I just switched over to Virgin on one of their Talk and Text plan with 100mb of data. I know I could use the browser on wifi prior to me switching over, but now I can't and have observed the following:

    - With both wifi connected and Mobile Network ON: browser doesn't load but Facebook/Twitter/App World/Messages all work.
    - Wifi OFF and Mobile Network ON: Everything works as it should.
    - Wifi ON/connected and Mobile Network OFF: Nothing works.

    I don't believe it's an issue with my router as I have many other devices connected to it via wifi without a problem, and the Bold shows it to be connected with good strength. Service Status shows the phone is connected to Mobile Network even when wifi is ON and connected, I did see Service Status connected to wifi for a split second today, but that quickly reverted back to Mobile Network after I turned mobile network and wifi on and off a couple of times to test.

    Before I signed on with Virgin I had this phone on Fido PAYG with no data for a few days. Obviously none of the messaging functions worked as I was not connected to BIS, but at least the browser was able to connect to my home's wifi and that worked along with FB, App World, etc.

    Could it be that Virgin pushed some service books that restrict wifi/hotspot browsing? Anyone else using a BB7 device on Virgin experiencing the same issue? I know some people over at the UAE have the same issue and it was due to their carriers, but I wasn't aware that this happened here.

    Anyone have any ideas?

    Thanks!
    02-19-12 07:17 PM
  2. FuzzyFish's Avatar
    So it turned out to be a router issue. After resetting the router everything works as it should again, I didn't check the router first because everything else that was connected to it was fine and the Bold showed a good connection, I guess you just never know for sure.
    02-20-12 03:52 PM
  3. Hi Tek's Avatar
    when i use youtube wifi on/connected and connected to network it does not work. network only and it works fine.. im with virgin.
    02-20-12 04:01 PM
LINK TO POST COPIED TO CLIPBOARD