1. Great White North's Avatar
    There have been a lot of us that have been complaining with call quality issues on the new network. Some of you have even switched back to CDMA. I was VERY close to switching back myself, however, in the last 4 days or so, I haven't had one call quality issue. (Note that previous to this, 90% of my calls were unreadable).

    Am I niave to think that TELUS has fixed the call quality issues with the 9700?

    Anyone else that was having these issues notice an improvment too?

    I still get the "ME" error on a re-boot though
    ...and battery life is still not very good.

    I'm in Northeastern Alberta.

    Your input please
    12-16-09 02:45 PM
  2. tmac09's Avatar
    I'm in Edmonton and have noticed some improvements. Still have horrible signal/call reception at home in Sherwood Park though. And the battery life is pretty much worse than my old pearl.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-16-09 04:54 PM
  3. Great White North's Avatar
    Shoot... I will be spending all of next week in Edmonton, so hopefully I won't go back to having a bad experience!
    12-16-09 05:15 PM
  4. Toddske's Avatar
    I live in Fort McMurray and my call quality sucks on my 9700....I'm fed up with opening tickets so I think I'll get a Storm2 until their network is fully operational.
    12-17-09 04:38 AM
  5. anon(1341046)'s Avatar
    I had first 4 calls dropped since then it has been awesome
    12-17-09 11:11 AM
  6. Walshy701's Avatar
    I'm thinking about jumping on the HSPA network this week. Is the battery life that bad OP? I was under the impression that the 9700 had incredible battery life. How many days can you guys get through without a charge?
    12-17-09 11:12 AM
  7. anon(1341046)'s Avatar
    My battery lasts 2 day (vs my old 8230 that was bearly a day) and my G/F's curve that is just over a day. I have heard some of the newer (Non Official Telus OS updates) improve battery life but I have not taken the leap yet
    12-17-09 12:00 PM
  8. Great White North's Avatar
    I don't know why my battery life is worse then so many others that have this phone (reading from the 9700 forum). I am not a heavy user, and am down to 50% by the end of every day. I too have not taken the leap to a leaked OS.
    12-17-09 01:57 PM
  9. sirk25's Avatar
    I am in Fort McMurray too. I find the call quality somewhat questionable at times. Although I don't use my phone for voice calls all that much. I too get that ME error, not all the time, but most often. And my battery life sucks. I am lucky to get a full day without charging it somewhat. I don't think I am a heavy user by any means after reading on here how much some people use thiers.
    12-17-09 03:49 PM
  10. dr_pepper's Avatar
    I am in Calgary. Experiencing the ME error, but also dropped calls and terrible call quality. Interstingly enough, I also have a Hero with separate SIM and phone number. It's crystal clear, no dropped calls. Still the ME error though. What I'm getting at is that the ME error is Telus network issue, but the call quality and dropped calls may be a firmware/os issue.
    12-17-09 03:53 PM
LINK TO POST COPIED TO CLIPBOARD