1. jeditait's Avatar
    Ok so i picked up an unlocked BB Bold (9000) yesterday, got the SIM card and activated the phone with Telus. Voice works no problem, data will not connect.

    Checked the forums got some useful information regarding apn information and got all the apn's from telus, tried them all and its still not working.

    Connected the BB to Desktop Manager and where it shows what networks it supports they are all GSM, does not say HSDPA however RIM says that this phone will support it.

    Im running v4.6.0.303 (Platform 4.0.0.248).

    Ive tried registering the device and its not working, no service books have been sent to the device either. Do i need to update\downgrade the BB OS in order to enable the HSDPA compatibility?

    Any help would be greatly appreciated.

    Cheers
    12-07-09 08:57 AM
  2. mordenxp's Avatar
    Make sure Telus put you on a BlackBerry data plan. I had a problem when I switched from a CDMA to 3G phone that they put me on the wrong data plan (PDA instead of BB) so the BB data wouldn't work, but voice did.

    You can call their data support team at this number to verify: 18667717292
    12-07-09 09:01 AM
  3. jeditait's Avatar
    Ya i just called and had them add me to the Smart Phone 50 plan, originally they had added a Data package to the existing plan.

    Still not working.

    I did the diagnostics tests and it's still not connecting to a data network.

    Telus cant(won't) help...very frustrating.
    12-07-09 11:14 AM
  4. mordenxp's Avatar
    Are you sure the phone was unlocked correctly?

    Have you tried a wipe?

    Running the latest OS?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-09 11:16 AM
  5. jeditait's Avatar
    I checked to see if it was unlocked and the Network option says disabled. Have not tried a wipe yet....will this affect the unlock?
    Last edited by jeditait; 12-07-09 at 11:24 AM. Reason: fat finger
    12-07-09 11:18 AM
  6. mordenxp's Avatar
    Wiping will not affect the unlock

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-09 11:32 AM
  7. jeditait's Avatar
    Ok just wiped it, added the apn given to me by Telus and still a no go.
    12-07-09 11:42 AM
  8. mordenxp's Avatar
    Can you write in here all the service books for me?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-09 11:43 AM
  9. mordenxp's Avatar
    Also have you tried.a battery pull?

    Can you also goto options/advanced/host routing table and tell me what items you see there and if you see anything under host routing table? Or is it empty? If not empty haveyou tried to press menu and register to a hrt? Do you get a success email after?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-09 11:45 AM
  10. jeditait's Avatar
    Absolutely....thankis for your help btw!

    Wi-Fi TCP/IP Browser [BrowserConfig]
    Wi-Fi TCP/IP Transport [WCTCP]

    Thats it
    12-07-09 11:46 AM
  11. jeditait's Avatar
    Done thge battery pull numerous times, same with the Register under the HRT no success email ever recieved.

    In HRT theres no items.
    12-07-09 11:47 AM
  12. mordenxp's Avatar
    Ok this is telus issue then... You're not getting the provisioning service book. They have to help you out.


    Are you using the telus provided sim card and have you provided and made sure they have the right sim number and imei number on their end?

    Try that phone number again and keep trying. Until you get provisioned not much you can do

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-09 11:55 AM
  13. wxmancanada's Avatar
    Do you have a TELUS BIS account?

    If so, go in and make sure the IMEI and PIN settings are correct.

    If not, go to https://bis.na.blackberry.com/html?brand=telus and create an account, enter your IMEI, and your PIN and it will send all the TELUS service books to your device.

    This is what got data on my 9000 working.
    12-07-09 12:47 PM
  14. jeditait's Avatar
    Yaaay, its now working. Took 4 calls to Telus tech department to get it working.

    If your having this issue you need to call the Telus tech number - 18667717292 (thx mordenxp) and have them add the APN Code to your account. This will then enable you to use the bb.telus.com apn which will then allow you to access the 3G Data service.

    Thanks All.
    12-07-09 01:18 PM
  15. mordenxp's Avatar
    On another note, I just realized my 9700 from telus is already unlocked out of box, cool!

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-09 02:26 PM
  16. mordenxp's Avatar
    Glad you got it working

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-09 02:27 PM
LINK TO POST COPIED TO CLIPBOARD