1. laminak8330's Avatar
    So, I activated my phone and the internet stuff isn't available. I know I'm supposed to call the Sprint reps, but I'm too lazy, and I know there's a way to just set it up myself, all I need is the instructions.

    Oh, and I tried using BlackBerry Internet Service , and so at first it said that my account was deactivated or something, but now it says that the info is invalid. I used the info from my Blackberry Email Account thing.

    PLUS! If that wasn't bad enough! Well, my BB says it's OS 4.5, but it has no MMS, and I thought the OS 4.5 had MMS even though sprint originally didnt offer it or whatever. But on my last two blackberrys (one new, second was a replacement) both versions 4.5 had MMS. What to do... What to do...

    And I should probably add that my parents didn't pay their last bill yet, and I guess it's late....? Could that be a factor?
    Because due to that, I wasn't able to activate my phone online.
    Last edited by laminak8330; 12-17-09 at 02:02 AM.
    12-17-09 01:30 AM
  2. AZBBFAN's Avatar
    its easy, I did it for my friend a couple weeks ago, somewhere in options there is something listed regarding provisioning. Once you find it you have to provision the phone takes about a minute but you will literally watch the phone become a berry righ in front of your eyes. When they activate berry's sprint forgets to tell you this all the time
    12-17-09 01:34 AM
  3. laminak8330's Avatar
    Hmm.. so were can I find this provisioning button..
    12-17-09 01:42 AM
  4. laminak8330's Avatar
    Oh I think I found it! In case anyone wants to know its in Options -->Menu button --> Start Provisioning.


    All righty so, I found it, but it's not working!!! It provisions for a minute, then says "Provisioning is canceled..." WTH!!!??
    12-17-09 01:47 AM
  5. AZBBFAN's Avatar
    there it is!! I found it before, it is a CDMA/sprint thing but it will get things working if your phone is already activated, sorry my advice was so vague but it wasnt too hard for me to find...good luck
    12-17-09 01:50 AM
  6. AZBBFAN's Avatar
    damn, sprint doesn't have your data set up. CS is the only way to get it done, make sure you ask for blackberry support. sorry buddy, wish I could do more
    12-17-09 01:51 AM
  7. laminak8330's Avatar
    Aw man.. Thanks anyway Jeffers.

    Now about the MMS, I don't wanna ask them about that, so I'm hoping someone on Crackberry knows. The Sprint people don't seem to know the magic of Blackberrys.
    12-17-09 01:56 AM
  8. AZBBFAN's Avatar
    sorry, I dislike sprint CS in the worst way. usually the provisioning works without fail
    12-17-09 01:58 AM
  9. laminak8330's Avatar
    Ah, and what a surprise! It's past their working hours. I guess I'll have to make due with an internetless blackberry for the next 12 hours, unless someone knows how to fix this. Oh the agony...
    12-17-09 02:03 AM
  10. aleano75's Avatar
    to provision the phone, go to manage connections>mobile network options>blackberry button (options)>start provisioning
    it should go thru the process and you will see the data arrows in the top right corner working and the icons should start to show up.
    Good luck and let me know if this works.
    12-17-09 02:04 AM
  11. AZBBFAN's Avatar
    ummmm, he already tried that....
    12-17-09 02:04 AM
  12. aleano75's Avatar
    what model is it?

    nm 4.5 os = Curve
    Last edited by aleano75; 12-17-09 at 02:07 AM. Reason: found my own answer
    12-17-09 02:06 AM
  13. laminak8330's Avatar
    So now I get, "Provisioning Failed (error 1012)"
    12-17-09 02:13 AM
  14. AZBBFAN's Avatar
    they did not activate your phone correctly, probably they didnt set up your BIS/data
    12-17-09 02:15 AM
  15. aleano75's Avatar
    not to make excuses, cuz i would definitely be annoyed, but i saw in the store today 3 new curves that would not provision. we were on the phone with tech for awhile. i never did hear what caused it but 3 in the same hour makes me wonder if it was a network thing as opposed to human error. sorry buddy
    12-17-09 02:19 AM
  16. laminak8330's Avatar
    So is there anyway I can 'fix' this activation problem myself? The dude told me to press like ##6_______ and some other numbers I forget to activate my phone. Maybe something is screwed up over there.
    12-17-09 02:20 AM
  17. AZBBFAN's Avatar
    I wish I knew buddy, sprint is such a P.I.T.A
    12-17-09 02:27 AM
  18. laminak8330's Avatar
    I've been reading around, and I think the no MMS has to do with the no internet. So I'll just wait and see.

    Thanks for the help though!
    12-17-09 02:30 AM
  19. githalantas's Avatar
    If you got error 1012 you need to do a factory reset on your phone (##786 then hit the talk key). The reason for this is due to the incorrect username being prog. to the phone (Refurbs, phones from previous lines, or used phones cause this normally). You will need to call tech support or go into a sprint store to get the MSL for the reset, and no a security wipe wont fix it.
    12-17-09 07:20 AM
LINK TO POST COPIED TO CLIPBOARD