1. Jmmorales's Avatar
    Is it just me or does the signal with tmobile on the passport drop a lot

    Forgiven
    11-22-16 11:44 PM
  2. gariac's Avatar
    I don't have one, but you need to be more specific. If the signal is weak, yeah, it will probably drop. If it is like those weird iPhone drops, that is you are not moving and have a strong signal, then that is another story. I think the iPhone gets cranky if it overheats.

    Posted via CB10
    11-23-16 02:20 AM
  3. Jmmorales's Avatar
    Mainly a weak signal then drop and comes back up after a minute or so could it be there are too many different towers in my area

    Forgiven
    11-23-16 08:51 PM
  4. si001's Avatar
    Wow so many different threads with various reception problems lately, what is happening?
    11-23-16 08:59 PM
  5. gariac's Avatar
    Wow so many different threads with various reception problems lately, what is happening?
    When Tmo modifies a site, they take it down. Your phone switches to the "neighbor" site, which by definition is usable but not the best site for your location.

    I know the two cell IDs used at my house. My RSSI drops 30db when they turn off my closest tower. Now in my case, I'm really close to the best tower, so I go from -58dBm to say -88dBm.

    Tmobile's quest to have the highest data rate is noble I suppose, but they are constantly screwing with the towers. For instance, adding band 12 or going from 2x2 to 4x4 MIMO. I don't think my old Z10 can even do two streams, let alone four. So it peaks out at less than 50Mbps. The two stream users can reach 100Mbps. I've seen speedtests over 200Mbps, but I think they are 256QAM users.

    I've seen the "cherry pickers" out and about locally. Probably band 12, which is totally over promised in the bay area. Or perhaps prematurely announced if you prefer.

    I bought a g pad a few months ago. It gathers dust because I prefer bb10. I've contemplated getting a passport just to use around the house on wifi.

    Posted via CB10
    11-24-16 03:59 AM
  6. si001's Avatar
    I was not talking about T-Mobile in particular but blackberry phones in general. Lots of reception problems with priv/passport.
    11-24-16 05:54 PM
  7. Jmmorales's Avatar
    I was looking for that info actually thanks for that it's good to know

    Forgiven
    11-24-16 08:47 PM
  8. Catherine Sutthoff Slaton's Avatar
    I was getting a load of dropped calls, and texts that weren't going through. After many attempts on T-Mobile's part to remedy the situation including Cell Spot and Tower, I gave up. Just swapped out (no charge) my year old Classic for a Priv and here's why: T-Mobile claims that the BB Classic doesn't use (or maybe isn't compatible with) T-Mobile's low frequency. I've had the Priv for a few days and really miss my old BB. We'll see how she goes.

    Any one with other carriers experience dropped calls on their Classic?
    11-25-16 01:58 PM
  9. scrannel's Avatar
    I guess this depends on where you are, but oddly, my Z10 running the old 10.2.1.3442 connects better than my Dtek50. But, I'm in So. Cali.
    11-25-16 04:45 PM
  10. p1800nut's Avatar

    I know the two cell IDs used at my house. My RSSI drops 30db when they turn off my closest tower. Now in my case, I'm really close to the best tower, so I go from -58dBm to say -88dBm.
    Posted via CB10
    Interesting--where do you find that information?
    11-29-16 02:17 PM
  11. ezrunner's Avatar
    I didn't have an issue with my Passport

    Posted via CB10
    12-04-16 08:04 AM
  12. jdub1492's Avatar
    Me neither - I love my Passport, and now I have wifi calling. Life is good.

    Posted via CB10
    12-09-16 09:17 AM
  13. Old_Mil's Avatar
    Go check out the signal problem thread in the passport forum. This is a growing problem that extends beyond t-mobile or 10.3.3.
    02-12-17 10:18 AM
  14. Dmd74's Avatar
    Yes, I do. I carry both a Passport and a Priv. At times I would switch from my OG PP to my red PP and back again. When sitting in my office the Priv maintains a signal while the Passport, regardless of which one I was using at the time, would lose signal for a period of 30-60 secs and then get it back again.
    03-01-17 03:52 PM

Similar Threads

  1. Why I dont see anymore notifications on top of the screen?
    By mad_orsi in forum BlackBerry Passport
    Replies: 7
    Last Post: 11-23-16, 04:05 PM
  2. Turn on PRIV via ADB REBOOT command?
    By francees in forum BlackBerry Priv
    Replies: 9
    Last Post: 11-23-16, 02:24 PM
  3. help! is the Indonesian pin massage is spam or not for sure?
    By mohamad yasser in forum Ask a Question
    Replies: 4
    Last Post: 11-23-16, 05:31 AM
  4. Passport unbelievable price on Amazon
    By fanBBRY in forum BlackBerry Passport
    Replies: 1
    Last Post: 11-23-16, 02:48 AM
  5. Replies: 1
    Last Post: 11-22-16, 09:41 PM
LINK TO POST COPIED TO CLIPBOARD