1. heathric's Avatar
    So you've just loaded the latest leaked software on your Blackberry and you can't install appworld, etrade mobile, facebook, ANYTHING... the message says your device isn't compatible or isn't supported.... HERE'S A QUICK SOLUTION.


    use your computer. first of all, if you're still on an old microsoft computer and still using internet explorer (against the recommendation of the U.S. CERT and Department of Homeland Security) stop using it immediately and download firefox

    it's faster and does more anyways.

    Ok, now that you have firefox, go to tools/addons. search for an addon name "user agent switcher" and install it.

    go to user agent switcher and add an agent. Call it blackberry. Next line down says "user agent"

    I have a BB Bold with AT&T, so I put in the following;

    BlackBerry9000/4.6.0.216 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102

    save that and use that user agent profile to visit any site that blocks you from downloading the blackberry app. You should be able to download it to your computer.

    either transfer the downloaded file to your BB in the normal file transfer way, or preferably right-click the download link and e-mail it to your BB.

    Your BB will now be able to install the file.
    10-17-09 06:56 AM
LINK TO POST COPIED TO CLIPBOARD