1. DaveInVan's Avatar
    For those of you using the Bold 2 on the new Telus network, how do you find voice quality, and are you having any dropped calls or "call failed" notices.

    Also, do you find the voice quality better, worse, or the same as your experience with the Telus CDMA network?

    I'm debating going back to the CDMA network, but wanted to see what others have experienced because maybe I just have a defective unit.

    Thanks in advance
    11-18-09 05:23 PM
  2. steve7602's Avatar
    For those of you using the Bold 2 on the new Telus network, how do you find voice quality, and are you having any dropped calls or "call failed" notices.

    Also, do you find the voice quality better, worse, or the same as your experience with the Telus CDMA network?

    I'm debating going back to the CDMA network, but wanted to see what others have experienced because maybe I just have a defective unit.

    Thanks in advance
    i love the bold 9700 its f****** amazing, the call quality is amazing as well, everything about the 9700 pleases me and im a very picky person when it comes to phone. the battery is so dam good to i had it 3 days of use and the battery was only on 60% were i only got one day out of the storm lol i give it 100 out of 10 lol if you have the bold stay with it!
    11-18-09 05:39 PM
  3. tmac09's Avatar
    I've had issues with calls dropped or not connecting and some weird dead spots. Sitting next to a buddy with a curve on cdma with a full signal and my phone is in SOS mode....little frustrating, but when I get a good signal, its great. I'm just hoping they work the bugs out sooner than later...

    Posted from my CrackBerry at wapforums.crackberry.com
    11-18-09 06:00 PM
  4. steve7602's Avatar
    I've had issues with calls dropped or not connecting and some weird dead spots. Sitting next to a buddy with a curve on cdma with a full signal and my phone is in SOS mode....little frustrating, but when I get a good signal, its great. I'm just hoping they work the bugs out sooner than later...

    Posted from my CrackBerry at wapforums.crackberry.com
    thats ****ty to hear man i have had no problems at all with mine YET lol i had the iphone for a week and i notice that when i called my buddy the signal was cracking up i could not even pick out what he was saying. so far with my bold tho i have had full signal all the time were every i go, hope your problems work out
    11-18-09 06:05 PM
  5. PresidentJFJ's Avatar
    Everything is excellent for me so far. More coverage, faster data and much, much better call quality since I usually have 5 bars everywhere now. **** I'm tethered right now and I can't tell the difference from an ethernet connection.
    11-18-09 11:21 PM
  6. djkorben's Avatar
    yah i've got the same issue, i even upgraded to the new firmware for the Bold 9700 that came out for rogers, and still, nothing. i talked to a REP from Telus and he finally admitted they're having network issues and to just wait it out.. awesome.. a brand new phone that barely works. mine is still rebooting by itself all the time, and i've swapped out handsets 3 times now.. yaaayy. waiting for new firmware patiently...
    12-07-09 08:39 PM
  7. steve7602's Avatar
    yah i've got the same issue, i even upgraded to the new firmware for the Bold 9700 that came out for rogers, and still, nothing. i talked to a REP from Telus and he finally admitted they're having network issues and to just wait it out.. awesome.. a brand new phone that barely works. mine is still rebooting by itself all the time, and i've swapped out handsets 3 times now.. yaaayy. waiting for new firmware patiently...
    im having a really ****ty experience on the hspa network, it the hspa really sucks, the bold is perfect but they told me to wait but im going back to cdma at least thats still works in the area my hspa wont,i hates to give up the bold its a perfect phone but i cant dealy with a network that wont let me make calls in certin areas so im going to sell my bold
    12-07-09 08:43 PM
  8. wxmancanada's Avatar
    I'm in Ottawa - and seems to have a great connection, no dropped calls, no network dropouts. I think we really have to wait until they completely roll out the network, remember it's still in its start-up phase.
    12-07-09 10:00 PM
  9. bbtrev's Avatar
    Me and a co-worker just moved to ours tonight. The data speed is amazing and my voice seems fine. My co-worker, however, sounds like he's using one of those voice disguising boxes that kidnappers use in the movies.

    I was having major slowness on EVDO after they launched HSPA, but we didn't know if it was the network or the BES we upgraded to 5.0 a couple days later . Now I know, the CDMA network (at least in my area) seems to have been severely impacted by the hspa launch.


    Vernon, BC

    6750 > 7510 > 7520 > 7250 > 8703e > 8330 > Storm > 8330 > Tout > Bold
    My Tenth BB is definitely the best ever, now all we need is the browser upgrade
    12-18-09 02:06 AM
  10. Walshy701's Avatar
    Toronto

    I just got it yesterday and it has been great. I've used it for about an hour over 6 or 7 calls and nothing but success. Very clear, no feedback noise, no lost signal. In fact I get full bars in my basement now. With my Storm I only got 1 bar and still dropped most every call I was on.
    12-18-09 12:00 PM
  11. jaycop#CB's Avatar
    I have had the phone for about a month now and had about 15 dropped calls, its weird because I lose connection in spots that have worked fine before. I have also been having a lot of problems with BBM not sending messages and being slow in general. My GPS is having a very hard time picking up my location so my google maps and Poynt apps will no longer work. They need to work these issues with the new net work out quick!!
    12-22-09 05:06 PM
LINK TO POST COPIED TO CLIPBOARD