1. damule6666's Avatar

    I unlocked my 8900 today. All went smooth and by the numbers...Or so i thought.
    Everything worked ok, until i noticed i am no longer getting e-mails and while i can log into some apps and even access the internet. I can not get onto uber twitter or app world and a few others.
    MMS and SMS as well as the regular phone service work just fine.

    When i try to go to my email settings to check things out i get this message.
    "Your device had a problem connecting to the server"

    Any ideas or help would be great!

    Thanks a bunch.
    12-03-09 06:05 PM
  2. amazinglygraceless's Avatar
    There has to be another issue as unlocking your phone would cause none
    of your issues. Unlocking has zero effect on apps.

    Try turning your radio off for a minute and then back on.
    12-03-09 06:12 PM
  3. BlackBerryr's Avatar
    Yeah unlocking probably has nothing to do with these issues. Don't know what would though...

    Posted from my CrackBerry at wapforums.crackberry.com
    12-03-09 06:20 PM
  4. aristile's Avatar
    Try a battery pull, that might be all there is to it:

    With your device powered on, pull the battery out, wait 20 seconds then put it back in.
    12-03-09 07:08 PM
  5. lilro's Avatar
    Did you get the blackberry specific data plan or just the regular one?? If you got the regular cheapo internet plan then most 3rd party apps won't work.
    12-03-09 09:16 PM
  6. damule6666's Avatar
    Thanks for all the input.

    I am still having trouble with it. But not all the time. I have indeed tried several batt pulls. all to no avail.
    And yep i do have a BB plan.

    I bought the code from a CB advised seller, and the phone worked flawlessly before.. Hmm i guess i will try them next.

    Thanks again
    12-04-09 01:59 PM
  7. damule6666's Avatar

    Well i have narrowed it down a bit.

    Whenever i am where there is WiFi everything works fine. i shut off WiFi and no email no twitter no anything that requires internet..
    12-04-09 07:20 PM
  8. CarrierUnlock's Avatar
    Sounds like your missing service books, resedn those and you should be fine.
    12-05-09 03:38 PM
  9. doxa sub750T's Avatar
    I agree, try to resend your service book. I unlocked quite a few BBs and never had this issue. Can't to unlock my 9700 so that I can permanently get rid off some stupids pictures and pushed downloadable apps.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-05-09 10:08 PM
  10. damule6666's Avatar
    Well i re-sent all my service books... Still nothing if i turn off the WiFi or leave the range of my WiFi.

    The SIM screen were you input the unlock code.
    What should it say after i type in MEPD now?

    Mine says

    SIM Disabled
    Network Disabled
    Network Subset Disabled
    Service Provider Disabled
    Corporate Disabled
    Phone Number:

    12-06-09 02:03 AM