1. spirez's Avatar
    Managed to set my Curve up no problem using the WPS push button service. It connects to the wifi and runs nice and fast, as expected.

    However, if i leave the house then come back later, it won't reconnect.

    In the manage connections tab wifi is still on and has a green tick in the check box. If i go to wifi options My profile is still saved and there is a green sign to show that the network is transmitting but there is no green tick there like there was when i first set up the connection.

    In options > mobile network i have the wi-fi preferred option selected.

    Any ideas?

    07-25-09 05:49 PM
  2. aristile's Avatar
    Cycle the power on your router. For more information, check the WiFi and UMA guide links in my signature.
    07-25-09 11:02 PM
  3. Gaiking's Avatar
    I had the exact same problem with my 8900. Wifi was very sketchy at home...sometimes on sometimes off...sometimes the phone wouldn't connect after coming home...I then found this solution and I have no more problems...always connects and I can even get the wifi connection 2 floors away in my basement. I cant post the link because I have under 10 postings...but I copied and pasted the info here in italics.

    I have a linksys router...but it might be the same no matter what router you use
    kinda long...but it helps:

    There are many causes for poor wireless connections, and many solutions:

    First of all, give your network a unique SSID. Do not use "linksys". If you are using "linksys" you may be trying to connect to your neighbor's router. Also set "SSID Broadcast" to "enabled". This will help your computer find and lock on to your router's signal.

    Poor wireless connections are often caused by radio interference from other 2.4 GHz devices. This includes wireless phones, wireless baby monitors, microwave ovens, wireless mice and keyboards, wireless speakers, and your neighbor's wireless network. In rare cases, Bluetooth devices can interfere. Even some 5+ GHz phones also use the 2.4 Ghz band. Unplug these devices, and see if that corrects your problem.

    In your router, try a different channel. There are 11 channels in the 2.4 GHz band. Usually channel 1, 6, or 11 works best. Check out your neighbors, and see what channel they are using. Because the channels overlap one another, try to stay at least +5 or -5 channels from your strongest neighbors. For example, if you have a strong neighbor on channel 9, try any channel 1 through 4.

    Also, try to locate the router about 4 to 6 feet above the floor, in an open area. Do not locate it behind your monitor or near other computer equipment or speakers. The antenna should be vertical.

    Also, in the computer, go to your wireless software, and go to "Preferred Networks" (sometimes called "Profiles" ). There are probably a few networks listed. Delete any network named "linksys". Also delete any network that you do not recognize, or that you no longer use. If your current network is not listed, enter its info (SSID, encryption (if any), and key (if any) ). Then select your current network and make it your default network, and set it to automatic login. You may need to go to "settings" to do this, or you may need to right click on your network and select "Properties" or "settings".

    If the above does not fix your problem, download and install the latest driver for your wireless card.

    Some users have reported improved wireless performance by switching to WPA encryption.

    If you continue to have problems, try the following:

    For wireless g routers, try setting the "Transmission Rate" to 54 Mbps.

    If you still have trouble, download and install the latest firmware for your router. After a firmware upgrade, you must reset the router to factory defaults, then setup the router again from scratch. If you saved a router configuration file, DO NOT use it.

    try this too

    Make sure you have the updated firmware...
    If required download the firmware from here

    Follow these steps to upgrade the firmware on the device : -
    Open an Internet Explorer browser page on a computer hard wired to the router...
    In the address bar type - the username blank & in password use admin in lower case...
    Click on the 'Administration' tab- Then click on the 'Firmware Upgrade' sub tab- Here click on 'Browse' and browse the .bin firmware file and click on "Upgrade"...
    Wait for few seconds until it shows that "Upgrade is successful" After the firmware upgrade, click on "Reboot" and you will be returned back to the same page OR it will say "Page cannot be displayed".

    Now reset your router :
    Press and hold the reset button for 30 seconds...Release the reset button...Unplug the power cable from your router, wait for 30 seconds and re-connect the power cable...Now re-configure your router...

    You should try to adjust it's wireless settings...

    Open an Internet Explorer browser page on your wired computer(desktop).In the address bar type - and press Enter...
    Use admin for both Username & Password...
    For Wireless Settings, please do the following : -
    Click on the Wireless tab
    -Here select manual configuration...Wireless Network mode should be mixed...
    -Provide a unique name in the Wireless Network Name (SSID) box in order to differentiate your network from your neighbours network...

    - Set the Wireless channel to 11-2.462GHz...Wireless SSID broadcast should be Enabled and then click on Save Settings...
    Please make a note of Wireless Network Name (SSID) as this is the Network Identifier...
    For Wireless Security : -
    Click on the Sub tab under Wireless > Wireless Security...
    Change the Wireless security mode to WEP, Encryption should be 64 bit.Leave the passphrase blank, don't type in anything...
    Under WEP Key 1 type in any 10 numbers please(numbers only and no letters eg: your 10 digit phone number) and click on save settings...
    Please make a note of WEP Key 1 as this is the Security Key for the Wireless Network...

    Click on Advanced Wireless Settings
    Change the Beacon Interval to 75 >>Change the Fragmentation Threshold to 2304, Change the RTS Threshold to 2304 >>Click on "Save Settings"...
    Also make sure you have the latest drivers for your wireless adapter...
    Now see if you can locate your Wireless Network and attempt to connect.
    Last edited by Gaiking; 07-26-09 at 08:59 AM.
    07-26-09 08:56 AM
  4. spirez's Avatar
    Thanks, i'll give it a try when i get chance. The router's not in my room at the mo so it's a pain to get to it!
    07-26-09 02:51 PM
  5. aristile's Avatar
    So, your stealing your neighbor's internet?
    07-26-09 03:49 PM
  6. aplata's Avatar
    I had same issues with both an 8900 and an Iphone. In router settings, I assigned ip address to each device so no need to keep resetting router in order to renew lease on IP. My $0.02

    Posted from my CrackBerry at wapforums.crackberry.com
    07-26-09 04:20 PM
  7. steven_a1991's Avatar
    Please tell me how to connect to a adhoc network....i'm using jave....
    07-27-09 08:19 AM
  8. spirez's Avatar
    So, your stealing your neighbor's internet?
    Well not really, considering i'm the one paying for it

    Cycling the power on and off worked but i dont want to have to do this every time!

    Do i assign an IP for the blackberry within the router or the phone settings?
    07-28-09 11:22 AM