1. 121291's Avatar
    I managed to connect to my home wireless, put in the code and everything, and the blackberry said it was connected.

    Went back to browser and it couldnt open a webpage, it just says ''unable to find the requested server''.

    My dad has the new curve, and his works fine, so it isnt the wireless thats gone wrong.

    Thanks.
    10-05-09 04:29 PM
  2. MrAOK's Avatar
    I'd pull the battery and retry, but the only other two options are the wifi is turned off, or, more likely, you didn't type the code right.

    you can sometimes see if that is true by trying to connect to another network somewhere (like in a coffee shop). If it works there, but not at home, you typed the code wrong.
    10-05-09 07:10 PM
  3. dongxanh's Avatar
    Same problem here. I currently have a new Wifi installed at home. My laptop and my Sonyericsson worked fine, but me BLACK BERRY did not. It could connect to the Wifi, but when I tried with browser, Jivetalk, Google map, etc... there were same error: bad DNS. But if I tried with other wifi at some coffee shops, it worked! Weird! Now I can use any wifi, except for my own one!
    Any advice would be appreciated.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-06-09 01:44 PM
  4. Sajan Parikh's Avatar
    In the browser hit the menu key, options, general settings...

    Change default browser to 'Hotspot' or 'WIFI'.

    Close browser and try again.

    Beyond that it may be an issue with your access point. Make sure there aren't any MAC filters.
    10-07-09 01:09 AM
  5. Reed McLay's Avatar
    Good advise. There is a built in Wifi Diagnostic you can use to verify your Wifi Connection status or Error message.

    Connections / Wifi Options. Menu / Wifi Diagnostics.
    10-07-09 12:26 PM
  6. healogix's Avatar
    i think i have the same prob
    but it happen just after i upgrade my 8820 new os version
    i can't connect to wifi at all ...
    why? anyone can help?
    10-10-09 06:56 PM
LINK TO POST COPIED TO CLIPBOARD