1. vp420's Avatar
    My home screen shows the network but the icon is gray. If you go to "manage connections" the network is displayed, but no green check. If you go to "set up wifi" you find the network when you scan and there is a green check at that screen. If you click "check details" all the info about the network is there. Checked the info against a co-workers Bold and all info was the same except device MAC. Icon still gray when you go back to homescreen (co-worker's white).
    01-06-09 03:03 PM
  2. Backes27's Avatar
    I had a problem with not being able to turn my wifi on at all. I just did a battery pull and everything worked normal
    01-06-09 03:09 PM
  3. xedge21x's Avatar
    I have the exact same problem as you. No idea how to fix it i''ve tried battery pulls 3 different operating systems and rechecked my wireless a hundred times I will be keeping an eye on this thread hope someone can help us.
    01-06-09 03:32 PM
  4. vp420's Avatar
    Tried a battery pull with no success. My next thing will be to install the OS unless anybody has any other ideas.
    01-06-09 05:28 PM
  5. K B's Avatar
    Do you have both "wifi selection mode" and "network selection mode" on automatic?

    I don't think I've had your problem before, but I remember having to have both those settings on automatic.
    01-06-09 05:34 PM
  6. vp420's Avatar
    Thanks for the thought, but settings are on automatic
    01-06-09 08:16 PM
  7. Tinyk's Avatar
    I had this when i dropped back to 214, if you take the tick out of network so you have no connections active then go to browser i found i was actually connected by wifi just not showing it.

    I tried several diffrent things but only way i got it back in the end was to delete the access point, search it again, save it then battery pull and it seemed to work ok after that.
    01-07-09 03:42 AM
  8. darkone338's Avatar
    Often find that I have to reboot my router occasionally, else I just get the grey WiFi icon on the BB sometimes.
    01-07-09 04:03 AM
  9. joonbugg's Avatar
    Sounds like you guys problem is the "dim grey" wifi icon not being able to connect, but for the last couple days, I have had NO WIFI icon at all. Did a battery pull here at my work, and still no icon. I only connect through wifi at home, so maybe since there is no wifi in my area at work, maybe thats why no icon. I thought the wifi icon should always be on the phone though.

    Update: After that last battery pull, I went to "manage connections" then set up wifi network. I scanned for wifi in my area for the **** of it, and it detected a wireless router from the Tax lady across the hall, lol. Unprotected network too, so I tried to connect, and it worked. WIFI icon is back and bright on the desktop. Of course, I disconnected from her router soon thereafter... heh heh.
    Last edited by joonbugg; 01-07-09 at 10:59 AM. Reason: Update
    01-07-09 10:44 AM
  10. vincesane's Avatar
    you need to have data enabled for it to connect. on mobile network, you need to enable data services.
    01-07-09 10:47 AM
  11. Summett's Avatar
    For some reason it seems like with this latest OS (217) that i'm having more issue with it connecting (and staying connected) than w/ other builds.

    But, when i have this issue i try a couple things, usually in this order to see if one of them will work:

    1.) Battery pull
    2.) Turn of WIFI signal (uncheck), then set up WIFI network, scan for networks, hit menu & choose refresh networks, then choose desired network.
    3.) Delete my saved network, set up WIFI network, continue w/ #2 above, enter security code (if you have one) as this will erase any saved setup info .
    4.) Delete any saved network, reboot router, set-up WIFI network, continue w/ #2 above, enter security code (if you have one).

    With this build usually #1 works. But having a Linksys router at work & Buffalo router at home, i find i never have connectivity issue with my Linksys (as others have stated on here). So, i think it has a lot to do with the type of router that you're trying to connect to.

    Just my .02! Hope it helps.
    01-07-09 11:02 AM
  12. marcsw's Avatar
    I've this issue with a La Fonero (www. fon.com). I'm on and will now upgrade to and see what will happen.
    With other routes no issue so far.
    01-07-09 02:47 PM
  13. bt224's Avatar
    Might also want to check your network to be sure you can connect. Might not be your phone. Reboot modem and router, then try again.
    01-07-09 02:58 PM
  14. marcsw's Avatar
    Might also want to check your network to be sure you can connect. Might not be your phone. Reboot modem and router, then try again.
    Hi bt,
    thx. But as I can connect with two other devices to my AP, it's not the router.
    And: .217 provides no solution for my issue
    So, waiting for the next beta
    01-08-09 07:58 AM
  15. badmelonfarmer's Avatar
    Yeah, got a similar issue. wifi is working great with other devices. With the BOLD I get the white WiFi logo when I connect, but as soon as I try to browse it times out, goes grey and sometimes goes back to GPRS browsing.

    I know it's not the router (netgear DG834) as other devices are working fine. it is not a signal strength issue as it does not matter how close I get. it's not interference as other devices are fine and there are no other wireless networks in the area.

    the bold used to be fine.

    running on .217 at the moment, but it has been the same for a while and various builds.

    batery pulls make no difference
    01-08-09 08:23 AM
  16. pingu666's Avatar
    Ive got the exact same problem, worked yestaday but not now, im running .216 aswell,worst thing is that I cant change my browser now, or access facebook or anything, stupid orange,stupid bold!!!
    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    01-08-09 08:35 AM
  17. swhammertime's Avatar
    Go to options.

    Advanced options.

    Host Routing table.

    menu click on "Wi-Fi[60]"

    Select "Register"

    You should now have a green checkmark!!!
    01-08-09 10:57 AM
  18. vp420's Avatar
    You are brilliant! The register thing worked perfectly! Thanks for sharing this.
    01-08-09 04:50 PM
  19. ckelly33's Avatar
    I have a Storm 9550 with the same issue...
    01-04-10 12:54 PM
  20. ckelly33's Avatar
    ...called VZW tech support who, once stumped, put me on "hold" which was followed by a dial tone....nice. No follow up call either.
    01-04-10 04:43 PM