1. 56Bulldogs's Avatar
    I have read alot of threads, called ATT, and BlackBerry. Everyone is at a loss. Basically when I search for wifi connections it locates them fine, but when I try to connect it fails stating "Unable to Connect, Reason: Unknown Network Failure".

    Any ideas? I hate to have to return the phone.
    02-29-08 03:14 PM
  2. Reed McLay's Avatar
    I can detect open hotspot when the signal strength is -90 dB, but I can not connect at that strength.

    A signal strength of -80 dB is enough to connect reliably.

    Have you found the Site Survey tool? It is an option in WiFi diagnostics.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-29-08 03:38 PM
  3. 56Bulldogs's Avatar
    Hi, just found it. It shows -40 dbm.

    According to the BlackBerry techs I have a strong signal they are just not sure why it isn't connecting.
    02-29-08 03:55 PM
  4. BivensSA's Avatar
    Sorry for the late reply, but this might help others, as I had the same problem at home.

    My 8820 would not connect to my home AP but would find others just fine. Check the MAC address of your AP according to the phone versus the actual MAC of your AP. Mine was one number off on the last field (it showed up as :33 instead of :32 like it was supposed to).
    04-26-08 06:15 PM
  5. dckeener's Avatar
    Ive been having the same problem> I have good signal strength and can find any network find, but when i try to connect it get: "unable to connect. reason: unknown network failure" every time, no matter what network.
    It really bugs me nobody can figure it out and the only reason i bought this phone is because it has wifi.
    05-04-08 10:33 AM
  6. heyluv4u's Avatar
    Have you tried disabling the VPN under security options? Try that and also make sure your web browser is set to the wi-fi browser.
    05-04-08 02:26 PM
  7. dckeener's Avatar
    web browser is set to wifi, when i had just got the phone i thought i was using the browser on wifi but i was using data and i cost me $20 to surf 4 webpages, so i will not make that mistake again. I will try vpn tomorrow.
    05-04-08 10:44 PM
  8. dckeener's Avatar
    disabling vpn didn't help in case anyone wants to know. I'm still at a loss
    05-08-08 09:26 PM
  9. mdx's Avatar
    Try disconnecting your wireless router, waiting and plugging it back in. Sounds silly, but it worked when 2 hours on the phone with tech support did not.
    05-14-08 06:18 PM
  10. mdx's Avatar
    05-14-08 06:20 PM
  11. superblackeagle's Avatar
    cant use Wi-Fi with out data plan.
    05-16-08 06:43 AM
  12. Buffalobill91's Avatar
    I had the same problem on my 8820, just changed to browser configuration from media net and internet browser to hotspot browser and now it works like a charm... I have been driving myself nuts trying to get it to work since I cancelled my data with at+t and told them to block my data so I didnt get charges 20$ to look at 4 websites either....

    all that needed to be done is have it changed to hotspot browser
    02-11-09 07:53 PM
  13. krutip15's Avatar
    i've disabled VPN

    MAC addresses match, as does the device number

    i'm at a loss

    and i can't call tech support because my phone is T-Mobile unlocked using Rogers network (
    02-28-09 09:14 PM
  14. krutip15's Avatar
    i went on my router's website

    and it shows that my bb is connected to the router


    what is wrong???

    any answers would help

    and i don't have a data plan but i read that you don't need wifi without data
    02-28-09 09:17 PM
  15. viperviper's Avatar
    i hv similar problem,...

    1. disconnect the mobile network.

    2. ensure battery power is enough or plug in the power source

    3. turn on the wifi option

    4. turn Data service on, don't worry becos your mobile network is off

    5. change the browser to wifi option instead of gprs.

    6. try to surf the net, u should see wifi logo and some arrows to indicate data transfer

    7. turn on the mobile network, try to surf the net and just make sure the wifi logo is still present, not surfing thru gprs or data service, else it will cost u alot.

    hope this help.
    03-01-09 03:28 AM
  16. krutip15's Avatar
    hey

    so what you said worked!!!!! THANKS SO MUCH!!! YOU ARE AMAZING!!!!

    but the problem is, that when i turn the mobile network back on, i turn off my data at all times, and i can't use the internet anymore.

    i know you said to make sure that that wifi logo is still present, but i'm nervous that i am using the data services when it is on. is there any way to have it turned off and working?
    03-02-09 09:37 PM
  17. wolf5808's Avatar
    This was driving me crazy as well with my Blackberry 9000 (Bold). Changing brower configuration to Hotspot solved the problem for me.
    07-09-09 08:23 PM
  18. sushistew's Avatar
    changing the browser config to hotspot worked for me, thanks for the posts.
    08-20-09 10:45 PM
  19. traviesomex01's Avatar
    try resetting your modem by pressing the reset button on the back of ur modem and entering all ur settings again trust me this work for me and now my ipod and my bbnextel work on wi-fi
    03-12-10 09:07 PM
  20. Tamsinmarie's Avatar
    I have a black berry curve 8520 and the wifi has been working fine, till a few days okay, it says im connected to my wifi and my works wifi yet when i try to open ANY page it says cannot connect to the internet.... anyone able to help!? PLEASE.
    08-14-10 07:28 PM
  21. Man Pun's Avatar
    I had the same problem on my 8820, just changed to browser configuration from media net and internet browser to hotspot browser and now it works like a charm... I have been driving myself nuts trying to get it to work since I cancelled my data with at+t and told them to block my data so I didnt get charges 20$ to look at 4 websites either....

    all that needed to be done is have it changed to hotspot browser
    I changed my browser config from media net to hotspot browser and saved but it has changed automatically to media net and am still struggling with not access to wifi
    08-03-11 04:59 PM
  22. Man Pun's Avatar
    Have tried everything but my blackberry pearl 9105 still cannot access my home wifi which every other device can. Please help.
    08-03-11 05:01 PM
  23. PsYcO killer's Avatar
    Hello
    I got a blackberry 9300 3g curve was using the wifi connection 4 3mounths with no problems I was conned to a open network one nith I went to sleep nd when I woke up the phone did not conet any more . I can see the network and the signal strength is very strong but when I tell the phone to connect then I get a error "failed to associate with the network"can anybody please help me
    11-19-12 03:47 AM
LINK TO POST COPIED TO CLIPBOARD