1. hashsi99's Avatar
    I don't have the storm 2, but been using a 8320 for a while and figured out that even when connected to wifi, it will only use wifi when connection to mobile network is weak. To get around this you have to select "wifi preferred" under your mobile network options. Then go to service status and it should show that you are connected to BIS via wifi. Also, your wifi indicator should now be lit up. Hope this works.

    Edit: if it doesn't light up, power off (not a battery pull) and power back on.


    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by hashsi99; 10-29-09 at 12:05 AM.
    10-28-09 11:59 PM
  2. RushTheBus's Avatar
    I appreciate the effort man, really nice of you to throw and give us some advice. Thing is, i don't see "wifi preferred" anywhere...
    10-29-09 12:15 AM
  3. hashsi99's Avatar
    I appreciate the effort man, really nice of you to throw and give us some advice. Thing is, i don't see "wifi preferred" anywhere...
    try under options, mobile network.
    10-29-09 12:18 AM
  4. hashsi99's Avatar
    try under options, mobile network. then connection preference.
    10-29-09 12:18 AM
  5. cat5shotta's Avatar
    try under options, mobile network. then connection preference.
    No such option.... I think this is verizon's doing. No wifi on the storm 1 now limited wifi on storm 2.
    10-29-09 12:20 AM
  6. RushTheBus's Avatar
    Thats not an option, all i have is:

    data services: on/off
    While Roaming on/off/promt
    Mobile network: VZW
    Network selection mode: auto/home
    network tech: global/gsm/UMTS/1XEV
    10-29-09 12:21 AM
  7. zeiroe's Avatar
    I cant find it there for the storm2 either ... I'm sure its here somewhere though.
    10-29-09 12:23 AM
  8. hashsi99's Avatar
    I cant find it there for the storm2 either ... I'm sure its here somewhere though.
    keep looking. this will most likely solve the problem, I was having this same issue with my curve until i found this option. I also notice that my service books have a wifi service book (but this may only be because of UMA)
    10-29-09 12:29 AM
  9. ketchupfreak's Avatar
    I'll check for this when I get back home. I noticed that my wifi logo wasnt lit.
    10-29-09 12:42 AM
  10. ketchupfreak's Avatar
    Hm...Cant seem to find it either.
    10-29-09 02:09 AM
  11. franchise101's Avatar
    I have seen wifi prefered too, i am having the same problem and it seems like the phone is just waiting to be authorized to use wifi..something is not right
    10-29-09 02:19 AM
  12. Cruizer_8's Avatar
    I was messing with the settings on my storm2 and stumbled across it, but can't for the life of me remember where I saw the option at. What is even worse is that I forgot to enable it while I had the chance.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-29-09 02:24 AM
  13. ketchupfreak's Avatar
    I think I may have seen it when I first set up my wifi on the device. I cant find it at all now. =(
    10-29-09 02:58 AM
LINK TO POST COPIED TO CLIPBOARD