1. Curve.Bk's Avatar
    okay, so i just got my curve yesterday and i love it. but the only problem is the wifi. i have a linksys router and i have several computers connected to it with no problem, same with my xbox360. but for some reason when i search for a connection, it says no networks. so i than imput it manuelly and it still wont work. so after that i went to the router settings and changed the WPA to WEP and it worked, but it still didnt connect all the way, it waits 5 minutes to connect than says that it has expired?! i tired again and still the same problem. but as soon as i change the WPA to WEP everything looses its connection and fails. so right after it i have to change back for everything to be connected again. i also no its not a wifi problem with my phone cause i can connect to any local place with it, even my schools wifi i get! so whats the problem?! i need HELP!
    11-14-09 01:19 PM
  2. Reed McLay's Avatar

    Getting the Wifi protocols correctly matched should solve your problem.

    The first place to look is:

    Connections / Wifi Options. Menu / Wifi Diagnostics.

    If your are correctly connected, you will see two green check marks and a successfull connection message. If not, there will be an error message we can use to diagnose the problem.

    11-14-09 01:48 PM
  3. Curve.Bk's Avatar
    still doesnt work after following those instructions cause once i changed my router settings to work with my blackberry, my whole network was down and i had to re do everything. my router is set for a WPA settings, so is their any way i could make my blackberry read WPA ?
    11-14-09 05:08 PM
  4. stev32k's Avatar
    Press the menu key -> manage connections -> set-up wi fi network -> scan for networks -> if it finds more than one network make sure to select the one you want and save the name. Select WPA-PSK and manually enter your security key save the settings re-boot the phone and you should be good to go. If you still have problems it may be related to the other devices on your network and you will need to set-up QoS.
    11-17-09 09:38 AM