06-20-10 08:58 AM
38 12
  1. kalbo08's Avatar
    Modulation Type: Where is this located?
    04-25-08 05:27 PM
  2. Reed McLay's Avatar
    Inside your Router and Curve.

    Among the many choices your Router offers, the one that matters is 802.11g or Wi-Fi.

    We know your Curve is working becasue it connects to your friends Router, just a matter of getting it connected to yours.
    04-25-08 06:54 PM
  3. kalbo08's Avatar
    Is there like a code I have to put into my Curve? Or adjust the setting of my router?
    04-25-08 08:38 PM
  4. Reed McLay's Avatar
    The easy way is to use Wifi Setup on your Curve.

    It will search out and attempt to connect to an available signal.

    If that does not work, you need to troubleshoot your setup. The best way to do that is reset everything to factory defaults. If you can't connect that way, you know you have a more serious problem.
    04-25-08 08:50 PM
  5. kalbo08's Avatar
    Thanks Stoner for the info, I got the wifi to connect. Question though about UMA, is the UMA only offered with a network plan? my Curve is unlocked and I dont have a plan at this time. I have connection now with my wifi, and Im trying to make calls through my wifi connection.
    04-28-08 01:18 PM
  6. Reed McLay's Avatar
    The way I understand it, T-Mobile offers H@H as an option to their offering.

    You may be able to select it without a BIS (Data) plan. If so, you can still use the Voice over Wifi, but not messages.
    04-28-08 10:20 PM
  7. johnnysc22's Avatar
    Originally Posted by aardvarq
    Thanks to all above, I finally have success connecting my wifi to my 8820.

    Router: D-Link 614+ (with the two antennas)

    Here are the settings that I think may matter from the Advanced Tab --> Performance screen:

    Basic Rates :
    TX Rates :
    Preamble Type :
    Long Preamble
    Authentication :
    SSID Broadcast :

    4X Mode :

    On the DHCP settings, I too assigned a static address to the Blackberry's MAC
    I am using MAC filtering
    I changed the channel number to 2

    So far, this works.

    This solved my issue with dlink 614+ (one antenna).

    I was doing one change at a time to try and see what was actually causing the error. I was still getting errors until I changed the settings for
    Basic Rates :
    TX Rates :

    These were originally set to the 22Mbps, which seemed to cause the problem.

    Thanks so much for your advice!!
    12-22-08 02:46 AM
  8. dfb8085's Avatar
    Might as well be the first to post. The wifi on my 8820 is driving me crazy. I turn the wifi on, search for my home network...It finds it, no problem...Then I enter the wep key and it comes back with the error message "unknown network failure" I have called ATT, more then a few times, the router company which is 2wire home portal (and more then five years old), they sent me instructions that are way above me to start changing codes on my router...I have tried everything from changing my password on my router, using six different wep key's...nothing works..I'd like to know if some routers are just not compatible with the 8820?? For the record, I ordered a new router yesterday from ATT/Cingular, I think its called a Westville Gateway....is there anything on the 8820 that I have to re configure? Or, anything on the new router I must do when setting it up to get it to work? Any suggestions would be greatly appriciated.
    Did you ever get it to work. This is driving me crazy. I too have a 2wire home portal and you know it doesn't have as configirable stuff as high end routers. Anyway I get the unable to obtain IP address error message. I am very dumb when it comes to this stuff and only had the blackberry BOLD a week. Please keep any answers short and dumbed down where a child can understand it. I have tried taking the wep code out in the 2wire but made no difference. This phone belongs to my wife so it never is in my possession very long to really get down and dirty with it. I need help and maybe I want have to contact ATT or Blackberry for help.
    Last edited by dfb8085; 04-09-09 at 08:36 PM.
    04-09-09 08:33 PM
  9. rntmvp's Avatar
    This solved my issue with dlink 614+ (one antenna).

    I was doing one change at a time to try and see what was actually causing the error. I was still getting errors until I changed the settings for
    Basic Rates :
    TX Rates :

    These were originally set to the 22Mbps, which seemed to cause the problem.

    Thanks so much for your advice!!
    Old thread I know, but wanted to thank you for this post. My tx rates were at 22, and I changed to 1-2-5.5-11(Mbps) and was online in 2 seconds with my
    dlink 614+ (one antenna)
    Thanks again,

    06-17-09 02:00 PM
  10. PoLoBwOy's Avatar
    how can i get my tmo 8900 bold on wifi to connect to a tethered iphone broadcasting its wifi with mywi?
    01-06-10 02:30 PM
  11. slopoke's Avatar
    Look I know this post is EXTRA old, However those with the D-link Router who cannot connect and get code W002 or W010 the post below fixed my problem. It was the advanced settings he/she mentioned at the very bottom of the post. I hope this helps someone else, and sorry for reviving an old thread, but it helped me greatly.

    I've been having probelms connecting my 8320 with a D-link DI-614+ 802.11b router/access point. Sometimes the blackberry would see it and sometimes not, but I could never connect.
    I messed with everthing in the blackberry and on the router. I had to enter the ssid manually many times. I tried different channels used an open system for a while and finally I've had success. I want to share my experience in the hopes of helping someone avoid this frustration.

    Throughout my attempts the blackberry always seemed like it was about to connect but then it would say the the Wi-Fi connection failed with an error code of W002 or W010.

    Sometimes I would get an error about DHCP. So I followed the advice in forums and told the router to assign a specific IP address to the blackberry's MAC address. I also moved that IP address into the DMZ (outside of the router's firewall) just incase the problem was the firewall blocking some ports that the blackberry uses.

    These are good things to try if you're having a problem. I don't have conclusive proof but I believe my problem was something different.

    The D-Link 614+ supports more than the 802.11b standard it has enhancements that allow 22 Mbps when paired with the proper D-Link PC card. I believe that turning off these and other wireless preformance enhancement features was the key to making the Wi-Fi connection.

    In performance dnder the advanced tab of the DI-614+ web management interface I limited the speed to 11Mbps and turned off 4x mode (don't know what that is).

    I've been able to turn WEP back on. The the point of all this writing is have a look a see if your access point has some advanced wireless settings that you can change giving it "plain vanilla" standard compliant behavior. That said, your mileage may not be much better than mine. I'm not seeing very fast page loads so it seems the blackberry and access point are not playing well together. So maybe the best thing is to save a headache and buy a new access point.
    03-04-10 05:16 PM
  12. Absolute199's Avatar
    I get connected to the wifi but the browser says unable to connect contact your service provider...
    06-07-10 02:42 AM
  13. peterbitar's Avatar
    hey lk i have a prob i find my network i write my pass it saves it but wen i go 2 the browser they write :you are not currently in an area that can handle data communicATION.as a result,the browser cannot retrieve any web paages please try again when you are in a different lcation service provider if the problem persist and same **** at my friendz house and bluetouth with evry fckin ceel they tell that bluetouth connection failur plz help!!!!
    06-20-10 08:58 AM
38 12