1. hammerhand's Avatar
    So, I've read through several threads and haven't found any solutions to my problem, and the closest thread to being useful (but still not solving my problems) is a year old.

    I've read through various boards and haven't really found any answers to my problem (or any problems quite like mine, as far as I can tell).

    When I try to use Wifi on my 9700, whether for the browser, Pandora, whatever, nothing seems to load and the phone switched to my 3G connection and loads everything fine. For example: I'll have wifi on, white logo and everything, and open my browser to browse the internet. The wifi logo shows in the top right corner. I go to open a web page and the loading bar will pop up with "Requesting..." for ~20 seconds while nothing happens. After those 20 seconds or so the wifi logo disappears, 3G with the BB logo pops up and the page loads a couple seconds later.

    This happens on both wifi networks I have tried. One is my home network and the other is an AT&T hotspot in the Starbucks I work at.

    Anyone have any ideas what the problem might be? Thanks in advance!

    Edit: Somehow missed this post before, but step 9, the engineering screen, seems to have solved my problem

    Edit: It may have worked, but it was sucking my battery like a mofo. I switched back to normal and my web pages seem to be loading properly with wifi.
    Last edited by hammerhand; 05-28-10 at 08:36 PM. Reason: Issue Solved (Hopefully!)
    05-28-10 05:06 PM