1. 1812dave's Avatar
    I've got wifi working, but if I turn off the mobile network in "manage connections" the wifi doesn't work. Shouldn't I be able to use my wifi to connect to the internet without having the Verizon network enabled?

    ALso, with them both enabled, how can I tell if the phone is utilizing the wifi for the internet instead of the 3G??

    I tried the "Hotspot" browser and I still can't browse with wifi if the mobile network connection is disabled.

    WHAT am I misunderstanding about WiFi on the S2???
    Last edited by dave1812; 10-31-09 at 03:31 AM.
    10-31-09 03:21 AM
  2. DD1968's Avatar
    I can use wifi when my mobile network is off in manage connections. I am on a 8900 but in the uk on gsm, so I don't know if the cdma thing would be causing this? I can use the wifi browser without even a sim card in my device...??

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-09 03:30 AM
  3. Testingchip's Avatar
    Yes you should. If you can't do it with the phone data turned off you are not hooked up on wifi.
    10-31-09 03:30 AM
  4. olta777's Avatar
    Go to options> advanced options> host routing table> BB key > register now. Wifi has been addressed by vzw so should work well

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-09 03:36 AM
  5. DD1968's Avatar
    is your router name displayed where the carrier name usually is?
    Is your wifi symbol grey or white.

    In my options > mobile network there is a Connection Preference option, which I can choose "wifi preferred", this will make the device use wifi over the mobule connection when you have access to wifi... HOWEVER... I'm reading in some threads that that option doesn't seem to be there on the storm 2, but maybe it's hidden somewhere else...?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-09 03:41 AM
  6. 1812dave's Avatar
    Go to options> advanced options> host routing table> BB key > register now. Wifi has been addressed by vzw so should work well

    Posted from my CrackBerry at wapforums.crackberry.com
    I can't find "bb" key. I saw "wifi" as the second item in the host routing table screen. there are zillions of "verizon" entries and no others. I tried the "register now" on the wifi item and it sent "something". Still have gray icon and in the manage connections, status, the wifi isn't connected.
    10-31-09 03:54 AM
  7. 1812dave's Avatar
    is your router name displayed where the carrier name usually is?
    Is your wifi symbol grey or white.

    In my options > mobile network there is a Connection Preference option, which I can choose "wifi preferred", this will make the device use wifi over the mobule connection when you have access to wifi... HOWEVER... I'm reading in some threads that that option doesn't seem to be there on the storm 2, but maybe it's hidden somewhere else...?

    Posted from my CrackBerry at wapforums.crackberry.com
    I can't find connection pref. where is it?

    router name not anywhere on my home screen.
    10-31-09 03:56 AM
  8. 1812dave's Avatar
    in the Services Status screen my wifi network isn't listed: it says "not connected" for all 3 items--active profile, ssid, type
    10-31-09 03:58 AM
  9. 1812dave's Avatar
    i went to the wifi diagnostics screen. it shows it's trying to associate with network, and keeps failing.
    10-31-09 03:59 AM
  10. DD1968's Avatar
    I can't find connection pref. where is it?

    router name not anywhere on my home screen.
    On my 8900 its in "options > mobile network" but I've read it's not there in Storm 2, but haven't been back to see if users have found it yet.
    The router name/ID will appear where the carrier name is (above the clock) on your homescreen when connected...
    There seems to be lots of stuff on the blogs/main site so it's prob not something you're doing, sounds like a known issue...

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-09 04:04 AM
  11. olta777's Avatar
    Dave, the BB key is the blackberry logo key on left of back button.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-09 04:39 AM
  12. 1812dave's Avatar
    Dave, the BB key is the blackberry logo key on left of back button.

    Posted from my CrackBerry at wapforums.crackberry.com
    oh, that's what u meant. I automatically hit that to get the menu to do the resend. LOL! in any event, i did resend on the "wifi" entry.
    10-31-09 04:58 AM
LINK TO POST COPIED TO CLIPBOARD