1. huynhct's Avatar
    Hi all,

    I recently purchased an ATT branded Bold 9900 to use with my current carrier (t-mobile). I updated to 7.1.0.523 (AIS Thailand) as well. How do I get Wifi calling to work on the phone? I've checked network> mobile network and I don't have an option for selecting "wifi preferred". Is my only solution to downgrade to the latest official t-mobile OS?
    07-16-12 02:16 PM
  2. Chopper110's Avatar
    Are you sure it should work with your service provider?

    Here in the UK it will only work on Orange and with a branded Orange phone.
    07-16-12 03:20 PM
  3. adamn216's Avatar
    Same here, AT&T 9900 on T-mobile. I spent about 6 hours with T-mobile and then Blackberry support. Last thing they told me is there is most likely an AT&T service book that is not allowing the T-mobile one from being installed properly. They didn't seem to think it was as simple as copying the right one to the Blackberry. I am not so sure but I am at a loss to which ones I would need.

    edit: incidentally, downgrading to the latest T-mobile (7.1 rel998) didn't help.
    Last edited by adamn216; 07-17-12 at 12:04 AM.
    07-17-12 12:01 AM
  4. adamn216's Avatar
    OK, after a little digging, I found this link detailing on how to setup a connection profile. Additionally, since the device was from AT&T I had to manually install the t-mobile certificates. Look around on the web for current links. Now, I am still not seeing the UMA connection active but now I do have a wifi-preferred option in the connection menu. Hopefully this will give you a nudge in the right direction. Good luck. I will update tomorrow when I have some more time to look things over.
    07-17-12 01:58 AM
  5. adamn216's Avatar
    OK, I confirm it works with my AT&T phone. Everything to fix this is on the forum. I had everything, I just typoed an entry like the fellow here.

    psgw.t-mobilesgws.com

    Call tested just fine although it was a bit spotty since my public wifi at work has 1 bar. I feel pretty good about it. Good luck.
    huynhct likes this.
    07-17-12 09:47 AM
  6. huynhct's Avatar
    Thanks for the update! I know this worked on the torch, but wasn't sure if it was the same for the 9900... guess it is.
    07-17-12 11:39 AM
  7. adamn216's Avatar
    No problem. Update for today, with a decent WiFi signal, the calls work flawlessly. I tested an open and a WPA2 PSK enabled AP. It's a little clunky at extreme ranges and it's not a problem with no hand off to cellular since I have absolutely no carrier signal at home but it serves my purpose well.
    07-18-12 10:45 AM
  8. mikeycollins13's Avatar
    Are you sure it should work with your service provider?

    Here in the UK it will only work on Orange and with a branded Orange phone.
    Clearly you are shooting from the hip here. I use a Rogers from Canada and it works fine...

    Just enter Orange UMA details:



    eZ as Cheese
    07-18-12 06:17 PM
  9. xandermac's Avatar
    OK, after a little digging, I found this link detailing on how to setup a connection profile. Additionally, since the device was from AT&T I had to manually install the t-mobile certificates. Look around on the web for current links. Now, I am still not seeing the UMA connection active but now I do have a wifi-preferred option in the connection menu. Hopefully this will give you a nudge in the right direction. Good luck. I will update tomorrow when I have some more time to look things over.
    I love how he Ripped off my guide. At least he credited me in his post.

    http://forums.crackberry.com/forum-f...mobile-513720/
    Last edited by xandermac; 07-19-12 at 10:50 AM.
    07-19-12 10:48 AM
  10. GsusReigns's Avatar
    I'm on a mac and I can't get the certificates on my phone. I also tried emailing the links to my phone and opening but it goes to a website that's not there. Any thoughts?
    01-01-13 10:47 AM
LINK TO POST COPIED TO CLIPBOARD