1. Jaybee8's Avatar
    hi guys..I've already posted a thread in the 9700 forum and wasn't able to get any answers..

    I've googled a million different ways to fix this..my 9700 will not connect to my home WPA network.I entered it as a PSK security type..I keep getting error message "Connection failed due to incorrect network credentials. Please verify this profile's security settings."..i know 110% that my network is WPA..and there is no specific option for that..I've also tried it as no security..any ideas?..wifi is a deal breaker
    any help would be GREATLY appreciated..thx
    12-03-09 04:18 PM
  2. Zolutar's Avatar
    need to give alot more info, what kind of router, how are you connecting?

    You actually might get better luck from the router manufacturer website.
    My bold 9700 connected to my D-Link DGL-4500 easily via PSK
    12-03-09 05:32 PM
  3. dvancao's Avatar
    I too am having issues with my WiFi, but just slightly different. I have a Linksys WiFi router (WRT54GX v2). It's set up for WPA Personal with TKIP. On my Win 7, I have WPA-Personal with TKIP. On BB9700, I have it set as Pre-Shared Key (PSK). Nothing else would work. Sometimes it connects, most often, I get the EAP Authentication Failure too. It keeps on trying and trying. At work, I use PEAP and I don't have any problems with this.
    Last edited by dvancao; 12-15-09 at 06:17 PM.
    12-15-09 06:14 PM
  4. dvancao's Avatar
    I changed my router settings to WPA2-Personal with the same TKIP. Then changed all of my clients, including BB9700 and that seems to work better. I am testing it by turning on/off WiFi on the BB9700 and it has been connecting consistently.
    12-16-09 08:52 AM
  5. blackhound's Avatar
    am gettin an error"connecting to IP address failed"... what could be it?
    03-31-10 04:31 AM
  6. pilsbury's Avatar
    more than likely your router has a password that you set during installation. also sometimes when youre setting up wifi on your berry, it will ask for the PIN number on your router
    03-31-10 06:34 AM
  7. tschlaef's Avatar
    OP, any chance you have MAC address filtering turned on? I would turn all security off, reboot the router, then delete the WIFI profile for your home system from your phone. Probably wouldn't hurt to do a battery pull then re-scan for WIFI networks but enter the required information manually. If you can get it working then go back and add the security back in.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-31-10 07:15 AM
  8. hitman52's Avatar
    im having the same problem failing to get ip address. This problem just started happening. Did not happen when i first got my 9700. My laptop is working fine and every other computer in the house is connecting fine. 2wire router tried resetting but nothing working.
    03-31-10 08:52 PM