1. Sauravbhattarai's Avatar
    Ok guys here is my problem..ill try to make it as much detailed as possible so u can precisely point out the problem,
    What basically happens is my blackberry connects to the router but cannot access the internet over wifi,
    before i begin...this is blackberry bold at&t unlocked. im not on a data plan and yes everything was working fine until few days back...it just happened all of a sudden..i dont see any particular reason. Ive default browser as hotspot...and yes ssid keys etc..all are correct.

    ok now this is my wifi diagnostics report

    wi-fi

    Current profile : TRENDnet
    SSID: TRENDnet
    AP MAC Address: 00:14:d1:44:EA:6E
    security type: No Security
    Association: (green checked)
    Authentication: (green checked)
    Local IP Address: 192.168.1.102
    Signal Level: -32dBm
    Connection Data Rate: 54Mbps
    Status: Network acquired
    Authentication Faliure Reason: (blank)
    Network Type: 802.11b/g
    Network Channel: 6
    Pairwise Cipher: none
    Group Cipher: none
    Gateway Address: 192.168.1.101
    DHCP: (green checked)
    Primary DNS: 192.168.1.101
    Secondary DNS: 0.0.0.0
    DNS suffix: (blank)
    Subnet Mask: 255.255.255.0
    Server Domain Suffix: (blank)
    Certificate: Not Applicable
    Software Token: Not Applicable
    Hotspot Code: Blank
    Hotspot Message: Blank
    Hotspot status: Not Applicable

    I dont understand what has happened...i know this has happened to so many others here..but i didnot see any solutions...
    Further ive these screenshots from the page of my router..u can see my blackberry as well as my laptop both are connected and im using the same internet to post this thread from my laptop but i cant use it in my bb.
    http://i.imagehost.org/0890/access-filter.jpg
    http://i.imagehost.org/0988/Device_information.jpg
    http://i.imagehost.org/0301/lan_DHCP.jpg
    http://i.imagehost.org/0694/status-wireless.jpg
    http://i.imagehost.org/0103/WAN.jpg
    http://i.imagehost.org/0995/Wireless_Basic.jpg

    Im using trendnet 432brp router and firmware is uptodate..internet is an ADSL connection.

    PLEASE SOMEBODY HELP!!!
    ps: i can connect to other hotspots sometimes...but not always.
    10-25-09 11:21 AM
  2. Sauravbhattarai's Avatar
    i dont know what magic it is but i disabled the DHCP accidentally and then it worked like a charm...damn im happy this thing was really frustrating me....if anyone of u have same problem then try disabling dhcp. It worked for me may be it will work for you too
    10-25-09 11:47 AM
LINK TO POST COPIED TO CLIPBOARD