1. ronb1224's Avatar
    I have a new BB 9330 and am having a problem with it that's driving me nuts.

    When I'm at home connected to my WIFI network, I periodically get the message "Unable to find requested server". (title says "requested Network" - this is a typo). The issue is very sporadic, happens when I try to access various websites, and then will magically resolve itself seconds later.

    I've searched this forum and all over the web and it appears that this has been an ongoing issue with the BBs for some time, and yet, I've found no real solutions.

    Additional information:

    - Running OS 6.0
    - Have tried resetting to factory settings
    - Wireless router is a D-LINK DR-615. Have 4 other WIFI devices connected to this router with no issues.
    - No issue connecting the BB to the router.

    Called tech support who instructed me to do a full reset and if that didn't solve the problem to bring it in for a new device. I did that, it didn't work, and now the new BB is behaving in the exact same way.

    I've seen at least one other thread where the "solution" was to try another router - that's not a solution. That's a shot in the dark.
    Last edited by ronb1224; 01-28-11 at 01:59 PM.
    01-28-11 01:55 PM
  2. ridesno159's Avatar
    I think this is just a bug in OS 6 that needs to be ironed out. I get this from time to time too on my 9650. I'm about 99% sure it's not a router issue. Happens to me at home, school, work, friend's house, brother's house, and my parents. I don't think all those routers are bad...

    I've ran every leak, and many hybrid OS' on my 9650, and this issue has been on every single one. It happens randomly all over the web too, I can't narrow it down to a single website even.

    I'm also at a loss on what to do. I've thought about calling Verizon to complain, but I'm not sure that will get me anywhere. I really don't want to deal with getting a new phone because I don't think that's the issue.

    I'm not sure about you, but it will always open the link/page when I click it a again after I get that stupid error.
    01-28-11 02:37 PM
  3. ronb1224's Avatar
    Spot on - couldn't agree more.

    I worked in IT for 28 years, so no stranger to solving technical issues, but this one just looks and smells like an OS issue.

    Put it this way, I have 6 different devices connected to my WIFI network (not all of them PCs) and they connect with no issue and stay connected.

    This issue is very intermittent and is exactly as you describe. I might go back and re-install 4.5 to see if I have the same issue, but from the posts I've read, this has been an issue with the BBs for several years. What's troubling is that I've yet to read anything that resembles a solution.

    I've deleted my network from the BB, and done a battery pull, factory reset, tried different settings. Seems like in the old OS a lot of people solved this by choosing the Hotspot browser. That isn't an option with OS 6.0.

    At this point, unless someone comes along with some new information, I'm of the opinion that is OS related.

    Of course the guy from Sprint tried to tell me that it was because I was in a weak coverage area!! I tried to explain to him that I was talking about WIFI and my weak coverage had nothing to do with it. He then proceeded to talk in circles and say things like "let's see....how can I explain this to you....". I knew right then that he was clueless.

    Surely someone has figured this one out.
    01-28-11 02:48 PM
  4. green_ember's Avatar
    This is definitely an OS 6 issue. I've had the problem on my 9650 since I installed the very first OS 6 leak and it's been in every version since. I even went back to 5 to see if it was my phone and the issue went away. They definitely need to do some work on the WiFi networking in OS 6. Under 5, my phone used to pick up the proxy settings from the BES at work and I could surf the net with no problems. Now, under 6, my phone won't connect to BIS at all due to not picking up the proxy settings from the BES. (I'm not attached to the BES, but under 5, I didn't have to be for internet access only)
    01-29-11 08:39 AM
  5. Fatoomah's Avatar
    I agree it seems to be an OS 6 issue. I have the same problem with my bold 9780. I can only connect via wifi 10% of the time, the rest of the time I get "Unable to find requested server". I initially thought it was my Thomson router but my daughters 9300 connects without any problems. Very annoying! I hope there's a fix soon.
    01-30-11 01:33 AM
  6. branflakes's Avatar
    When I get the error, it seems to be when you're on WiFi, but the signal is weak. I work in IT and I run into it at home in certain spots in my house that have poor signal or if I'm at a client, on their WiFi, but their signal is weak.
    01-30-11 02:08 AM
  7. justchrissy's Avatar
    I am having the same issue with my home wifi on my Torch 9800 on ATT...it seems to work when it wants to. When I called tech support they had my do several things and several hours (about 6 hours) on the phone to trouble shoot before they decided to send me a new phone through the warranty exchange. Once I got the new phone and set it up it worked fine one day but not the next. Its hit or miss if it actually works correctly or not...
    I have tried to disable and delete the wifi settings and register it, have cleared out my browsing history, done a battery pull, and reset the router and checked my internet connections and have no trouble. My lap top is connected and stays connected with no issues. I have even put my sim card in my old BB Bold 9700 and it connects and stays connected to my wifi with no issues.
    I have to agree that this is probably a bug with the operating system.
    RIM needs to fix this!!!
    05-16-11 07:17 PM