1. viper_1986_1986@yahoo.com's Avatar
    I have a unlocked AT&T 8900 - paid for this myself.
    I unlocked the UMA so now all the settings are usable.
    I have t-mobile as my provided with unlimited data plan.

    Everything stated in here has been done with the cell tower OFF, wifi ONLY!

    Router settings:
    WRK54G - Firmware Version: 1.58.03
    Secrutiy: WEP on - i read advanced settings can cause it to not work so i tried WEP.
    ANY and all firewalls: OFF
    portfowding: OFF (see below!)
    DMZ: ON - straight to the cell phone! So the world don't even see my router, if someone hits my public IP they go straight to the phone.
    QoS: HIGH for the cell's MAC.
    NO other deviced are plugged into the router

    I have used a laptop just to double check to to make sure everything is proper.


    On the cell phone, WiFi is turned on, pulls an auto IP x.x.x.101, which is DMZed, gets the proper gateway, DNS, ect...
    Can ping yahoo google cnn, ect....
    Can do a DNS lookup on yahoo google cnn....

    Get emails, and can surf the net just fine.
    The, would-be-bars says "off", which i believe is where UMA should appear?

    The errorcode is blank, very odd?
    But under it, it states the DNS server couldn't be reached.
    Using the ping tool i pinged the DNS, and it hits both of them.
    I also used a server 03 system to act as a DHCP and forced the cell phone to use the server as a DNS, still same problem.

    Wi-Fi
    Current Profile: linksys
    SSID: linksys
    AP MAC Address: 00:13:10:9C:AB:01
    Security Type: WEP
    Association: Successful
    Authentication: Successful
    Local IP Address: 192.168.1.101
    Signal Level: -56 dBm
    Connection Data Rate: 54 Mbps
    Status: Network acquired
    Authentication Failure Reason:
    Network Type: 802.11b/g
    Network Channel: 6
    Pairwise Cipher: Not Applicable
    Group Cipher: Not Applicable
    Gateway Address: 192.168.1.1
    DHCP: Successful
    Primary DNS: 24.93.41.127
    Secondary DNS: 24.93.41.128

    DNS suffix: austin.rr.com
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate: Not Applicable
    Software Token: Not Applicable
    L3 Auth:



    UMA
    Connection Pref.: Wi-Fi Only
    UMA Wi-Fi Available: Successful
    Connection: Error
    Error Code:
    Status: ISP error. DNS server cannot be reached.

    Reg. UNC Address:
    Registration: N/A
    Authentication: N/A
    Serving UNC Address:
    Security Gateway Address:
    Cell Info.:
    Cell. handover to UMA failures: 0
    Cell. rove-in failures: 0


    ~~~~~~~~~~~~~~~

    Anything would help.
    Once tmo found out i had an unlocked phone i was told "sorry" they supported unlocked AT&T phones, but not the enabled UMA feture on them....
    09-30-09 12:39 AM
  2. aristile's Avatar
    I am curious as to what exactly you meant when you said "I unlocked the UMA so now all the settings are usable". Please elaborate on that before we dig in to deep into this issue.
    09-30-09 12:45 AM
  3. viper_1986_1986@yahoo.com's Avatar
    AT&T phones dont have UMS form what i understand.
    Mine had no UMA settings, no prefer wifi settings.

    So i used this site
    absolous.no-ip.c om/projects/escreen/
    To get the unlock code to the escreen, from there i added tmobile as a UMA.

    And following this
    allunlocks.c om/UMA.html
    To get the proper server name.
    09-30-09 12:57 AM
  4. aristile's Avatar
    That's the process ... I would make absolutely sure that you have everything exactly correct. Also be extremely careful when going into the eScreens because you can very easily render your device completely useless if you screw around in there. That goes for anyone reading this thread that gets any ideas.

    If you are sure that the settings are 100% correct then the problem may be with your router. Check the UMA Guide link in my signature.
    09-30-09 01:02 AM
  5. viper_1986_1986@yahoo.com's Avatar
    Sometimes you just got to be re-told.
    I 5x checked that page again to make sure i made every char was correct, turns out i was missing a letter in the top URL.
    I was really thinking the AT&T just had me doomed and the few sites i saw claiming it worked were just BSers

    But this does work!
    AT&T Unlocked phone, using tmo sim card and i can make UMA calls.


    Can't tell the difference from 1 bar from tower and UMA, but this will be nice when going out to my parents house, no bars there, never :<
    Or if i ever travel!


    Thanks for pointing out my retardiness.
    Nice little info page for the UMA
    09-30-09 01:27 AM
  6. aristile's Avatar
    User error, sucka!!!!

    Glad you got it sorted out.


    Hey look on the bright side ... you got me to 8,000 posts!
    09-30-09 01:29 AM
LINK TO POST COPIED TO CLIPBOARD