1. marceverett's Avatar
    Hello everyone,

    My ATT Curve 8300 is unlocked and I have brought it to use with prepaid sims while I am overseas for four months. I have went into smart dialing and changed the country code to the correct current country code and that is allowing me to have caller ID that matches to local numbers in my address book. If someone calls me from the number 052-xxx-xxxx, it matches and shows correctly. However, if I receive an SMS from that same person, it does not match with the address book because it shows the SMS from +972-52-xxx-xxxx, because when you use the country code here, it cuts off the 0 that is in front of all numbers.
    If I make the entry in the phone book as +972-52-xxx-xxxx then I get correct callerID matching on the SMS but not on the voice calls.
    What gives? Do I have to choose to have callerID for either one and not the other or does anyone know how I can fix this?

    Thanks so much.
    01-30-08 07:17 AM
  2. marceverett's Avatar
    Setting the national number length to 9 fixed the problem. Thanks.
    01-30-08 08:02 AM