1. OTCHRussell's Avatar
    Just wondering why this happened:
    I just downloaded an Amazon app "The Great Courses " on my Z30.
    When I tried to open it, a pop-up said I needed Google Play to use it!!
    I was about to delete the app, but after a delay it opened and worked perfectly.
    Opened it again, and it said the same thing, but then worked.

    Any ideas?

    9000 > Q10 > Z10 >Z30>Z30>
    02-18-16 07:45 PM
  2. Denise in Los Angeles's Avatar
    I've seen it happen with other apps. Part of the annoyance of using android apps on BB10. If you had not waited, you would just assume it did not work!
    02-18-16 08:54 PM

Similar Threads

  1. Kindle App for PlayBook?
    By Thannor in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 05-03-20, 04:51 AM
  2. Possible to login to Android CB Forums App through Twitter?
    By paulwallace1234 in forum Site and App Feedback & Help
    Replies: 3
    Last Post: 03-18-16, 09:36 AM
  3. I can't uninstall android apps
    By pth92 in forum Ask a Question
    Replies: 5
    Last Post: 02-21-16, 01:17 PM
  4. Blackberry app download count - Google Play Store
    By niccomar in forum BlackBerry Priv
    Replies: 10
    Last Post: 02-18-16, 08:35 PM
  5. Replies: 1
    Last Post: 02-18-16, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD