1. Verminator's Avatar
    Has anyone run across this?

    I have a BB Curve 8330 and my daughter has a BB Pearl 8130.

    On the Pearl 8130 she can aquire a GPS location "Where I Am" in about 10 seconds.

    On the Cruve 8330 it takes me at least 10 MINUTES or MORE to acquire the same GPS location "Where I Am".

    Do any other Curve owners experience this incredible delay in acquiring satellite acquisition, or is it perhaps a defect in my individual 8330??

    Thanks for any replies...
    07-07-08 10:20 AM
  2. slovak's Avatar
    I have the same issue with all gps apps on my Curve except for Telenav, but that's a pay service and I'm not paying
    07-07-08 01:42 PM
  3. soarin's Avatar
    I have also experienced this....not 10 minutes....but about 5 minutes was my maximum wait....and it always occurs after a battery pull....

    Any time I connect after the initial acquisition after a battery pull its instant! I am not using any third party software, just using BB Maps... I also find that my Curve 8330 connects quicker after a battery pull if I am outside and moving versus being inside and sationary :-)

    Posted from my CrackBerry at wapforums.crackberry.com
    07-07-08 01:46 PM
  4. exhausted's Avatar
    Has anyone run across this?

    I have a BB Curve 8330 and my daughter has a BB Pearl 8130.

    On the Pearl 8130 she can aquire a GPS location "Where I Am" in about 10 seconds.

    On the Cruve 8330 it takes me at least 10 MINUTES or MORE to acquire the same GPS location "Where I Am".

    Do any other Curve owners experience this incredible delay in acquiring satellite acquisition, or is it perhaps a defect in my individual 8330??

    Thanks for any replies...
    same thing. i had an 8830 that was a lot faster too.
    07-07-08 01:49 PM
  5. lumihiutale's Avatar
    I have a 8330 that had lots of problems with the gps locking satellites. I found this solution and it worked beautifully for me.

    Go to 'Options' select 'Mobile Network' then switch that from 'Automatic' to 'HOME ONLY'.
    11-11-08 03:51 PM
  6. Zick's Avatar
    I have a 8330 that had lots of problems with the gps locking satellites. I found this solution and it worked beautifully for me.

    Go to 'Options' select 'Mobile Network' then switch that from 'Automatic' to 'HOME ONLY'.
    What will changing this do exactly, is there any negatives?

    My 8330 Curve also takes forever to pickup a GPS signal.
    12-01-08 04:00 PM
  7. TvTechGuru's Avatar
    That's really odd. I can't see what provider you have but on Sprint I can acquire my location within 10 seconds. You definitely have a problem with satellites finding you.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-01-08 08:31 PM
  8. Zick's Avatar
    That's really odd. I can't see what provider you have but on Sprint I can acquire my location within 10 seconds. You definitely have a problem with satellites finding you.

    Posted from my CrackBerry at wapforums.crackberry.com
    I'm on US Cellular. I've even been outside with full bars. Sometimes it picks it up other times it doesn't.
    Never had this problem with my Garmin.
    12-01-08 08:54 PM
  9. bobbysan's Avatar
    I have an 8310 on AT&T. The problem I have is that if I have to make two turn within a tenth of a mile, I'm sometimes past the second turn before the map catches up to where I am. Is there any way to speed "Navigator" up? Memory usage or, anything?
    01-02-09 04:06 PM
LINK TO POST COPIED TO CLIPBOARD