1. 2xJ's Avatar
    Hey all, I've had my Storm2 (VZW) for about two years now, but this is the first time I can't shake a problem with a battery pull and normal troubleshooting.

    Over the past 24 hours, my phone has gone to a virtual standstill when it comes to anything data related. Fixmo Speedtest shows < 51 avg. Kbits/s, when normally it's in the X000s and higher (it fluctuates, but is certainly nowhere near 51 normally). Webpages either never load, or load partially; same with apps (ex. Facebook app won't load profile pictures, images, etc.). Similarly, with the FB app, it never loads walls, profiles, etc. just as an example of the data problem.

    I've also tried on two separate WiFi connections (my home and a friend) and while it seems to improved slightly, it still takes much longer than usual to load pages (and again, FB won't fully load).

    I tried a battery pull (several, actually, to no avail). I downgraded my OS from 1082 to 1015 just to see if that would ameliorate the issues; no dice (I'm in the process of reloading 1082 as we speak). FWIW, I've never completely wiped the phone and loaded an OS from scratch - if you think that may help, let me know.

    The other problem I've noticed is that coinciding with this data problem has been a similar dysfunction with the GPS capabilities of the phone. For the most part, Google Maps, Weatherbug, and other GPS-heavy devices would work most of the time even in buildings. Now, even if I'm standing outside, the GPS either can't detect my location or is (in the case of Google Maps) estimating based on cell towers (I think).

    I'm kind of at a loss here because nothing has changed other than these problems randomly popping up. I'm thinking there may be some physical problem with the radio, but I don't know why that would have happened. The phone worked fine yesterday, and has run without any sort of hiccup for some time. So if anyone has any tips - or is experiencing some sort of data slowdown on VZW (I think that's ruled out with the WiFi and GPS problems, but I figured I'd give it a shot). Any help would be most greatly appreciated. Thanks!

    Update: 8/22 The problem now isn't data, but the GPS. Data seems to be back to normal for the most part (speedtest times are normal again). The GPS seems to be totally non-functional however. The location icon on the home screen is active, and the device is set with Location On/location aid on (etc.) and I've also confirmed that apps have permission to use the GPS. For example, I tried four programs that use the GPS location: Blackberry Protect, Google Maps, Poynt, and Weatherbug. None of the apps can determine my location, and give a variety of reasons for the failure but all related to the GPS. BBP couldn't find it and noted that the GPS data was unavailable (or possibly in a building, which it wasn't when tested). Google Maps can only triangulate based on cell towers, and is good to about 3100 meters, and either says "waiting for device GPS" or "GPS temporarily unavailable." Poynt was going off of "cell site location" rather than GPS location. Weatherbug just spits out the standard "cannot locate" message and I'm forced to input a zip code.

    Anyone else experiencing GPS difficulties on VZW (or otherwise)? Do you think a full phone wipe would fix these issues? I've never had to wipe the phone but I'm willing to try anything at this point. Any help is, as always, greatly appreciated!
    Last edited by 2xJ; 08-22-11 at 07:09 AM.
    08-21-11 08:07 PM
  2. 2xJ's Avatar
    ...and after a little digging, it seems like there may be an outage for GPS data across Western NY State (which encompasses my area), though it came from a droid forum:

    droid gps not working - Android Forums
    08-22-11 07:14 AM