1. Martyn1988's Avatar
    Hi all,

    This is my first post here, and it's a problem my wife's having with her Blackberry 8520. We've changed broadband service providers and the new account was activated today. I've managed to get on fine with my laptop, her laptop, my dell streak and both our iPods, but for some reason we're only having problems with her Blackberry.

    When I run the wifi automatic setup, it finds the connection, I enter the password and it says that it's connected fine. Then I go into the status, and there is no tick in the box, only a white hyphen.

    Now I've looked around and from what I could see it was due to not having a Blackberry package with the mobile provider. My wife does infact have a bolt-on with o2 for Blackberry, and it has been working fine up until this switch over. Has anybody got any ideas on what to do?

    Much appreciated,

    02-23-11 01:46 PM
  2. GTWalling's Avatar
    Some others will chime in, but to start check and make sure your Wireless Router is not using the N band. Blackberry will work on the B/G but not N.
    02-23-11 04:57 PM
  3. Martyn1988's Avatar
    Thanks for the reply GTWalling.

    I've tried switching the bands, but unfortunately it's not solved the problem. Any more ideas?
    02-24-11 01:20 PM
  4. GTWalling's Avatar
    You might want to try the information at this link.

    Good luck.
    02-25-11 08:10 PM
  5. jswaly's Avatar

    By any chance do you have a DLINK wireless router? If so then it is a 'bug', once you change your router you will be up and running. I have the same issue as I changed ISP to Sky who send out crappy DLINK junk!
    03-07-11 05:44 PM
  6. Martyn1988's Avatar
    No mate, just a BT Homehub 3. The problem is sorted now though. Here's what I believe sorted it for anybody else having the problem...

    I rang BT to opt out of BTFON and BT Openzone (not even thinking that this was part of the problem) and when they'd disabled it, the wifi icon turned white. It still wouldn't connect, so I changed her wifi option to wifi hotspot, and it worked.

    Hopefully this helps somebody else out.
    03-09-11 03:47 PM