1. bgwavrder's Avatar
    I'm attempting to upgrade a T-mobile 8320 to a 4.5 OS and have done the following:
    Downloaded Desktop Manager 4.5
    Deleted the vendor file
    Downloaded the 4.5 (Rogers) OS
    Backed up Device using DM

    When I open the app loader it does not show the 4.5 OS or the back-up file in the apps folder and I can only see these when I click on all files. When I click browse, I get a message that says there are no other applications for my device. Can anyone let me know if I missed something? I know there are other threads on this subject, but im not seeing what I may have missed on them.
    10-12-08 11:12 PM
  2. exelant's Avatar
    Go back and look for the vendor file. Which OS are you upgrading to. There's over half dozen 4.5s. What are the last two numbers? Anyway, if your device is plugged in when you start DM, it should look for the upgrade before you even open apploader.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-08 11:22 PM
  3. exelant's Avatar
    The vendor file is sneaky, it was reinstalled when you installed the OS. Check again, it will be there.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-08 11:29 PM
  4. bgwavrder's Avatar
    The last two numbers are .81. I'll try pluging in the 8320 before opening the DM.
    10-12-08 11:30 PM
  5. exelant's Avatar
    Yes, but check for that file. Humor me.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-08 11:33 PM
  6. bgwavrder's Avatar
    I looked and could not find it. I tried restarting and reopening the DM. It's still acting as if the vendor file has not been deleted.
    10-12-08 11:42 PM
  7. exelant's Avatar
    Oh yeah and Remember: After you've deleted the vendor file, and you plug your berry in, the DM apploader will look for upgrades, you'll click update now when it asks if you want to update. On the next page that comes up hit the options tab beneath Data Preservation and Device Backup heading. Make SURE you check the box to ensure the Backup Device Data Automatically During the Installation Process then click OK. You can also click the advanced tab and if anything you want installed like docs to go and bbm has an unchecked box. you'll need to check them to make sure it's installed. Then you can click next, then click finish. The process will start. DO NOT, I repeat DO NOT unplug your device until apploader says it is done. It will look like it is hanging up but it isn't. Go away and don't look at your computer for an hour. If you unplug early your berry will be bricked and you willl be screwed.Good Luck

    After you're done upgrading, do the following:

    1. Browser Settings: Browser settings for improved view. While in your browser, press menu key> options> browser configuration> check all the boxes> make sure browser is set to internet browser> show images set to On WML and HTML Pages> emulation mode set to BlackBerry> click back and save.

    2. Send Service Books: Click your internet email icon (the envelope with a gear in front of it)> click service books> click send service books.

    3. Register Device: Click options> click advanced options> roll down and click host routing table> press your menu key> select register now> click back and close

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-08 11:42 PM
  8. exelant's Avatar
    Uninstall the OS and then reinstall it to your pc, then delete the vendor file and try again.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-08 11:44 PM
  9. exelant's Avatar
    Did you double click the OS after you downloaded it and install it to your pc?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-08 11:45 PM
  10. bgwavrder's Avatar
    I'll try the above things you suggested. Thanks for all of the assistance.
    10-12-08 11:51 PM
  11. exelant's Avatar
    OK, don't worry about it . You do need to install the OS to your PC, then delete the vendor file from C:\program files\common files\research in motion\apploader, then plug your device in and start DM. Then follow the instructions I put up about backing up and the rest.
    Let me know how it turns out. Remember to not unplug untile it says it is done. It may look like it has hung up but it hasn't.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-08 11:56 PM
  12. bmcclure937's Avatar
    Follow the Upgrade Procedure Link in my signature simple enough...

    And the main thing you need to do is make sure this OS is meant for your device!! I did not think Rogers had OS 4.5 for the 8320, but I could be wrong...
    10-13-08 12:07 AM
  13. exelant's Avatar
    I wondered too, that's why I asked the version. Thta would certainly explain why it wouldn't load.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-13-08 12:25 AM
  14. bgwavrder's Avatar
    If I complete the upgrade will the Blackberry enabler feature still work? This is a T-mobile feature that is free. It enables messagong sms/mms without a data plan
    10-13-08 12:37 AM
  15. bgwavrder's Avatar
    Exelant,followed your instruction and it's ready to upgrade. Got a warning that makes me think my Blackberry Enabler feature may not work with the Rogers OS.
    10-13-08 12:47 AM
  16. exelant's Avatar
    The OS is standard, it won't be a rogers, it'll just be 4.5.0.xx

    Posted from my CrackBerry at wapforums.crackberry.com
    10-13-08 12:50 AM
  17. exelant's Avatar
    I don't know what enabler is, I have TMoble, though. Did you make sure you checked the backup restore option?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-13-08 12:51 AM
  18. exelant's Avatar
    I didn't know you didn't have a data plan. Why upgrade? You might lose the enabler, I don't know - I have a data plan. Not to be too nosey, but a BlackBerry without a data plan is just a phone. You could have save a lot of money.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-13-08 12:55 AM
  19. bgwavrder's Avatar
    Actually when you have wireless netork at home and at work and also frequent places with hot spots it works pretty well. I haven't seen any threads saying the feature would be lost. I'm also thinking T-mobile could add it back on. Just wondering if there would be a compatability issue with the 4.5. If like you are saying it's not rxclusive to Rogers it might be OK.

    You were right about the vendor file sneaking back.
    10-13-08 01:09 AM
LINK TO POST COPIED TO CLIPBOARD