1. j_p36's Avatar
    Hi I'm new to the forums, but I have a problem that's been bothering me lately. When I got my pearl one of the first things I did was figure out the GPS. I used BB maps and got it to work. I also downloaded Google maps and got it to work. But for the past few months every time I try to use my GPS or if I tell a friend with a blackberry how to use their GPS the same thing happens. I use BB maps and click "Start GPS navigation", then I get a message saying "Unable to acquire GPS lock". After that, any more attempts to get BB maps to find a GPS signal results in me exiting the program after it has been sitting in my dash for 15 minutes saying "Searching for satellites".

    -I do have the GPS turned on via OPTIONS>ADVANCED OPTIONS>GPS> GPS data source is set to Device GPS and GPS services are set to Location on. These are the only options.
    -Every time I've told it to start GPS navigation I have been outside with a clear sky.
    -Google maps just says waiting for GPS signal (and before I upgraded to the newer Google maps I could only get the GPS to work by making BB maps find the satellites then opening Google maps).
    -I've spoken on the phone with and emailed my carrier (cellular south) and no one knows anything about them blocking the GPS. They just say that the pearl just has a weak transceiver and suggest I stand in a open area at least 10 minutes.
    -I have tried various combinations of resetting the phone and turning on and off the GPS with no luck.
    -The last time I tried it I: turned the GPS to location off; reset the phone via softreset; walked outside; turned the GPS to location on; opened BB maps; clicked start GPS navigation. Within 1 second it popped up and said "unable to acquire GPS lock.

    Very sorry for the long post, I just wanted to make sure I explained the problem and how I've tried to fix it. Thanks in advance to all who offer advice.
    10-29-08 02:09 PM
  2. jeffh's Avatar
    No need to apologize for a long post. You provided the details needed to help us help you. Unfortunately, you've already done all the right steps. As far as your settings go, I don't know anything else to suggest. It sounds like something has disabled your GPS, or your hardware has failed.

    Go to a Cellular South store and try an 8130 there. Take it outside and test the GPS. If it works, you probably need a new phone. If it doesn't work, show it to the sales person and ask them to explain it.
    10-29-08 11:10 PM
  3. j_p36's Avatar
    I guess that's all that there is left to try, wish it had just been some kinda duh moment where I just had a setting wrong. Thanks for the reply though.
    10-30-08 10:51 AM
  4. j_p36's Avatar
    hmmm. so i upgraded to last night (from 4.3 something) and I tried the GPS on the way to work this morning and it worked... maybe its not just toying with me and will actually continue to work.
    10-31-08 09:15 AM
  5. jeffh's Avatar
    Interesting. It should have been working, based on the settings you detailed in your first post. So maybe upgrading the OS cleared some internal OS error that was disabling it. If so, it should continue to work. Let us know.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-08 09:44 AM
  6. j_p36's Avatar
    Ok, I tried it a few more times the day of the upgrade, and I tried it today. Even though a few times I got the "unable to acquire satellites" message I just backed out of bb maps and reopened or just used google maps and it worked great.
    11-03-08 03:18 PM
  7. j_p36's Avatar
    also, a co-worker of mine had never been able to get his gps to work. he upgraded to yesterday and got the gps working. (his carrier is also cellular south)
    11-04-08 04:25 PM
  8. brute650i's Avatar
    where can i download the new OS?I also have cellular south and cant get GPS to work.
    11-19-08 03:37 PM
  9. j_p36's Avatar
    Go to this thread, you can use either of the links in the first post


    p.s. this isn't the newest OS, just the newest OS that cellular south has put out. if you want the newest OS regardless of carrier check the stickies at the top of the Blackberry Pearl 8110,8120,8130 forum found

    Last edited by j_p36; 11-19-08 at 05:02 PM. Reason: added info
    11-19-08 05:00 PM
  10. RockAndRollAcdc's Avatar
    One thing I've found is if BM doesn't work, I do a battery pull and it then works fine.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-20-08 07:39 AM
  11. poettone's Avatar
    One thing you might want to check as well is that you are NOT on a wireless network. As with some applications they can't function while on a wireless network and this happens to be one of them.

    That was my issue when researching I was unable to find it anywhere but remembered another application stating that it would not work while on a wireless network and sure enough as soon as I turned mine off, my satellites could be reached.

    02-28-11 04:23 PM