1. tom1l21's Avatar
    I was wondering if anyone using the 8330 ever exerienced this problem. All three of these keys stop working at the same time. If one isn't working, neither of them work. If one is working, they all work. If its not working, I have to press the key around 20 times before it starts to work. Is this possibly an OS issue (I noticed a few glitchy things so far) or are those keys just toast? I purchased this device from a friend and am under contract through Verizon for a Pearl so I don't think I could give it to them to send in for a replacement, or can I? If not, can I buy the parts online? When I press them they feel fine, so I don't know if its the keys or the pad or what, but I need help this driving me crazy!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-08 02:39 AM
  2. masterdnater's Avatar
    Well if you don't have insurance on it through Verizon, your screwed. Call Verizon and tell them what happened. Maybe your friend is still under the one year manufacture warranty, you should have him call rim. Other than that, I don't know

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-08 02:50 AM
  3. tom1l21's Avatar
    Is it possible to go to Verizon and buy insurance on this device then send it to them for a replacement? If so, what is there policy on that? Preferably, id like to fix this myself if all I have to do is buy a part, but I feel as if its more than just that.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-08 03:07 AM
  4. johnmorganjr1's Avatar
    If you want to fix it yourself just get a new keyboard and pad. Those come with a new case sometimes. I'd check the warranty from Rimm first though.
    10-28-08 06:57 AM
  5. tom1l21's Avatar
    Phewwww, I'm going to be getting a replacement. I guess problem solved.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-08 07:41 AM
LINK TO POST COPIED TO CLIPBOARD