1. WurstBlackberryUser's Avatar
    So I recently tried updating my OS 5 to OS 6 on my desktop manager, but unfortunately I received a message half way through the "task progress" window when it came to "Load JVM and system software" on the list it "completed" and stopped. And I received this message
    "A fatal error has occurred while updating your device's software. Please try again."

    Anyone encounter this problem, or know how to resolve it. Any help would be much appreciated.

    Thanks guys
    03-09-11 03:37 PM
  2. pkcable's Avatar
    What state is your device in? Does it boot up, and is it on 5.0 still, or do you get an error 507, or an endless boot loop? No worries we will get you fixed up.
    03-09-11 04:26 PM
  3. WurstBlackberryUser's Avatar
    Everything is working fine after the message after the problem, the berry simply reboots itself after. The only thing that is odd is that the radio (mobile network, wifi, and bluetooth) is off. Any other time when I reboot my berry it turns on automatically. I forgot to mention for the longest time though when it does startup after a reboot a window pops up reading exactly this

    Uncaught Exception:
    net_rim_bb_phone_app(67) is
    not responding; process
    03-09-11 05:02 PM
  4. pkcable's Avatar
    Try the upgrade again use the apploader method listed in my signature in the above post. This post won't have my sig

    Posted from my CrackBerry at wapforums.crackberry.com
    03-09-11 07:10 PM
  5. zwoof's Avatar
    Yes..Redo the upgrade and use the apploader, not DM. Sounds like something didn't take correctly.
    03-09-11 07:14 PM
  6. mjx's Avatar
    backup and wipe first then try to load the OS again
    03-09-11 07:44 PM
  7. WurstBlackberryUser's Avatar
    Thanks guys much appreciated, I'll update you on the situation after trying it through apploader.
    03-10-11 01:11 PM
  8. BoldtotheMax's Avatar
    Some peeps have good experience with DM, others don't....apploader IMO is a better way to go.

    Good luck!

    Posted from my CrackBerry at wapforums.crackberry.com
    03-10-11 06:35 PM
  9. thiartc's Avatar
    Hi there.

    I have the exact same problem, so i checked out the apploader way. I downloaded the os btu when i try and install it i get an error msg that states the application loader is running and i have to stop it 1st before i can continue, but none of the blackberry apps are running, what should i do?
    04-18-11 04:19 AM
  10. trinibb's Avatar
    hi all,

    i have recently had this same problem with my bold 9700 . i would get the same fatal error message every time i tried downloading the os 6 from my desktop software (error msg on the same JVM task). i have since tried wiping my phone and re installing as well as searching day and night to find a solution for this problem.
    after days of mind-wrenching search i decided to visit the us blackberry website. i then proceeded to download the newest version of blackberry desktop manager software (to date) and deleted the software that i had installed using the cd provided with my phone. after this deletion i installed the new software that i downloaded( this installation was 5xfaster than the cd btw). i then plugged in my phone and like the old software it scanned and told me there were updates. i clicked it, expecting the same fatal error message and voila!!! it worked and my phone is successfully running os6.
    it seems to me that this was an issue with the version of blackberry desktop manager software you are running. my best advice would be to do as i did. if you are trying to update the os via the software you installed via the CD you got when you purchased your phone, delete it and download the latest version from blackberry website. then try the update
    i hope this is useful to you. i know how dumb it feels to keep trying and still get that fatal error message.
    good luck. hope this helps
    06-18-11 01:32 PM