1. elgodfather's Avatar
    My curve can connect to all the wifi networks except for the one at home. However I can connect to my home network using 2 laptops a nokia and an iphone.
    Does anyone what i can do ?
    i have an 8520, and i don't have BIS
    08-03-10 04:12 AM
  2. M_rk's Avatar
    so what does it say when you select 'set up wifi options' and then 'scan for networks'

    additionally you can try manually adding them...

    let us know what happens
    08-03-10 05:10 AM
  3. elgodfather's Avatar
    i should've clarified more. sorry about that
    my phone actually connects and i can see the connection name next to my gsm network, the problem happens when i try " wifi hotspot login"
    it always says " unable to find the requested server "
    though i can connect to the network with any other device as i said earlier, so what do you think ? what can i do ?
    thanks again
    08-03-10 10:25 AM
  4. anon(140126)'s Avatar
    Try resetting your wireless router. And then delete the saved profile on WiFi options. Then, try again.
    08-03-10 03:48 PM
  5. elgodfather's Avatar
    tried that. still the same, i can connect to the network but i can't log in to the wifi hotspot. it's drivin me crazy
    08-04-10 02:52 AM
  6. jfhj2's Avatar
    Not sure if this will help but can tell you an issue I have with the wi-fi and might be same for you. At work we have a wireless router hooked up out of the box without even security set up on it. My parents have the same brand router in their house. I connected to the network at work first and it works fine. While on a visit to my parents I tried to connect and it won't. It sees the routers as the same for some reason just because they are the same brand and right out of box. Apparently there is a way to go in and change the router settings so it will see it as different but I never bothered as it doesn't matter that much to me.
    08-04-10 11:13 AM