1. benedict gomes's Avatar
    Hi everyone!

    The new OS update had actually made me exited, but after that update the battery life is really going down... even the phone seems to getting heated up quickly which I did not come across before the update.

    I love my Z30 a lot... and this issue is making me go crazy..

    My OS is 10.2.1.2101.

    Posted via CB10
    03-17-14 06:31 AM
  2. qbnkelt's Avatar
    Hi everyone!

    The new OS update had actually made me exited, but after that update the battery life is really going down... even the phone seems to getting heated up quickly which I did not come across before the update.

    I love my Z30 a lot... and this issue is making me go crazy..

    My OS is 10.2.1.2101.

    Posted via CB10
    How long ago did you update? Sometimes updates need to "settle" a bit.
    03-17-14 06:38 AM
  3. benedict gomes's Avatar
    I updated it on 15th of March, I really had no issues before the update,.

    I really want to know what has this new update of 49mb got with it??

    Posted via CB10
    03-17-14 06:53 AM
  4. danielrivers's Avatar
    Give it time, if you have few accounts will take longer, warm phone is it sorting things out. See if still bad tomorrow

    Posted via CB10
    03-17-14 06:56 AM
  5. kifty's Avatar
    Supposed to be minor bug fixes. Mine was 37mb. Battery was worse at first, but has settled down now and is actually a lot better

    Posted via CB10 on my Z10
    03-17-14 06:57 AM
  6. benedict gomes's Avatar
    Give it time, if you have few accounts will take longer, warm phone is it sorting things out. See if still bad tomorrow

    Posted via CB10
    Thanks buddy, , people like you make us feel better... will surely give it time, will wait for another day or two, just got irritating as I love this awesome phone.

    Posted via CB10
    03-17-14 07:01 AM
  7. 1guitarguy's Avatar
    Same for me

    Posted via CB10
    03-17-14 10:36 AM
  8. benedict gomes's Avatar
    Hey everyone, I noticed one thing, the battery drains very fast and gets warm when it's on data network. But works great on wifi,.

    do I need to change anything in network settings???? Is there any chance of battery not getting so warm.

    Posted via CB10
    03-19-14 10:14 AM
  9. kifty's Avatar
    Hey everyone, I noticed one thing, the battery drains very fast and gets warm when it's on data network. But works great on wifi,.

    do I need to change anything in network settings???? Is there any chance of battery not getting so warm.

    Posted via CB10
    Tty turning off any location services

    Posted via CB10 on my Z10
    03-19-14 12:52 PM
  10. Jerale's Avatar
    Had the same issue after updating on T-Mobile. Just give it at least 3 days to settle. Battery will go back to normal.

    Powered by BlackBerry (Z10). Join my #BBM Channels C001227CF, C00476C37, C003829C9, C002454C9,C002190AC, C00120CE3
    03-19-14 01:08 PM

Similar Threads

  1. Blackberry Z10 STL100-1 battery issue
    By hareesh_blr in forum BlackBerry Z10
    Replies: 20
    Last Post: 02-13-15, 04:39 PM
  2. my bb playbook is loading all the time on facebook
    By Matthew Rogers2 in forum BlackBerry PlayBook
    Replies: 11
    Last Post: 03-24-14, 11:29 AM
  3. New 10.2.1 feature: native custom email notifications
    By Omnitech in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 03-22-14, 09:30 PM
  4. After using the Q10 and Z10..
    By ShaneVich1 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 03-18-14, 06:48 PM
  5. Last update rendered my Z10 useless on T-mobile
    By look30 in forum BlackBerry Z10
    Replies: 8
    Last Post: 03-18-14, 05:37 AM
LINK TO POST COPIED TO CLIPBOARD