1. Ilikephoning's Avatar
    I recently purcharsed a Blackberry. I installed Sprint Navigation, and it worked for the first time. However, when I try to use it now, it will just sit at the open screen. When I press the blackberry key nothing happens. The only option I have found so far is to hit the end button and go back to the application menu. Is there anything I can do to make this application work?
    09-02-09 04:49 PM
  2. Tõnis's Avatar
    Not to state the obvious, but mine didn't work right until I enabled GPS.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-02-09 05:30 PM
  3. Ilikephoning's Avatar
    My phone has GPS Services marked "Location ON" so I think I am ok there. I did work one time the first time so I guess it came "ON" I

    The problem seems to be with the application itself. Is there a way to reinstall the application?
    09-02-09 08:24 PM
  4. keepit dry's Avatar
    Did you try pulling your battery out for about 10 seconds? It seems tp clear up lots of problems when apps aren't working correctly.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-02-09 10:13 PM
  5. Ilikephoning's Avatar
    Thanks for the suggestion, it is funny you suggest that becasue everyone I know with a blackberry has problems with it and the first thing they do when a problem arises is pull the battery. Unfortuately, I have already tried this but had no luck.

    I don't know why this is so problematic on a brand new phone. Is it possible to just reinstall the application?
    09-03-09 05:51 AM
  6. Ilikephoning's Avatar
    Bump for help for these problematic phones.
    09-17-09 07:59 AM
  7. ChadsterDroid's Avatar
    Thanks for the suggestion, it is funny you suggest that becasue everyone I know with a blackberry has problems with it and the first thing they do when a problem arises is pull the battery. Unfortuately, I have already tried this but had no luck.

    I don't know why this is so problematic on a brand new phone. Is it possible to just reinstall the application?
    Yeah, you might try uninstalling it. Just go to Settings>>Advanced Options>>Applications and find Sprint Navigation in the list and press the BlackBerry button, and select "Delete."

    Restart the device. You'll see that the Sprint Nav app icon is still available. Just select it again to re-download and reinstall. Hopefully, that'll help.

    I had some problems with Sprint Navigation very similar to yours a few months ago and uninstalling and reinstalling did the trick.

    Good luck!
    09-17-09 09:21 AM
LINK TO POST COPIED TO CLIPBOARD