1. TheSweetmore's Avatar
    I bought my blackberry bold 9700 on Monday. I have an O2 pay as you go sim in the phone. Yes, i know you cant use network browsing on O2 PAYG so i want to use the WiFi feature instead.
    I am able to connect to my router easily. I have entered my WPA code and it says i am connected to the router in my house. However, when i go on my browser, and go to a website, i get the message "Unable to find the requested server." and am therefore not able to do any web browsing

    I have searched other for answers on forums, and I have done simple things like made my default browser to "hotspot" etc. I also used the Ping tool.. but it kept timing out. So im connected to the router, but cant access the internet. Any help or ideas?

    As i am using O2 PAYG i dont have a blackberry data plan. I read on this site that you dont need a data plan to use wifi, so that shouldnt be a factor.

    If i go on manage connections, it says WiFi On.. but next to it is a white dash opposed to a green cross which i get for my mobile network, could this be while?

    Any help would be much appreciated,
    07-16-10 05:58 AM
  2. cooldudie3's Avatar
    Is data services enabled in the Mobile Network options? Try restarting router and check that you can connect to the internet via your computer. Download Opera Mobile and see if you can connect through that.
    The white dash means it's turned on. The red cross means it's off.
    07-16-10 06:03 AM
  3. TheSweetmore's Avatar
    Hey, thanks for your quick reply

    Ive checked and yes data services is enabled. I have restarted my router but still get the same problem. I know my router and internet works because i connect to it everyday with my laptop and ipod touch. I cant download the opera mobile app because i cant get access to the app store without a data plan. I tried to download the app on the computer for blackberry, then transfer it across using my USB cable, but the blackberry said it couldnt read the file :S

    Any more ideas?
    07-16-10 06:35 AM
  4. RC_Oslo's Avatar
    Just out of interest, what happens if you disable the mobile network leaving WIFI as your only connectivity?
    07-16-10 06:58 AM
  5. TheSweetmore's Avatar
    yeah i tried that mate, i get the same message :/
    07-16-10 07:07 AM
  6. TheSweetmore's Avatar
    ive managed to get Opera on my blackberry. Just tried to load it up, and it says Installing.. but the installation bar has froze.

    thanks for the replies guys.
    when i use the DNS lookup for wifi settings, i used google as the host, and it just says "looking up www.google.co.uk..." as if its not getting any feedback. and Ping just times out.

    Does this help?
    07-16-10 07:21 AM
  7. RC_Oslo's Avatar
    Maybe something in your TCP or routing config is still forcing you to reference your carrier? I am by no means an expert in this area, but for example I have my APN settings (under options, advanced, TCP/IP) all set to blank and unchecked (and I can browse).

    Maybe you have some O2 details defaulted on your phone causing issues?

    btw, if you do have some details stored there you may also what to consider what the implications of trashing them are. Like I said, they are blank for me and all works fine!
    Last edited by RC_Oslo; 07-16-10 at 08:31 AM.
    07-16-10 08:16 AM
  8. TheSweetmore's Avatar
    if i try to connect to O2 active, which is using the mobile network.. i got the message "unable to connect to internet, please try again later." which is different. So it knows im trying to connect through WiFi.

    I then went into TCP/IP settings and the boxes were checked and defaulted to TMobile (which is what the phone was originally simlocked too). So i deleted that and unchecked the boxes. But still unable to browse through WiFi.

    07-16-10 11:03 AM