1. singularity2006's Avatar
    After my last update to the most recent OS on this forum, my bluetooth died. It worked a while, then just suddenly would not turn on anymore. After downgrading back 3 updates, and doing a brick update, bluetooth still won't turn on. Hit the check button and it grays, then it unchecks itself.

    Is my bluetooth shot? Is there any possible way to fix it?
    09-15-09 12:32 AM
  2. mrppinzon's Avatar
    Same thing with me! Looks like is a common problem on 8220s and is a shame for this great phone u.u I made a post about the same.. Search a few post down this (: I took my 8220 to a repair store and they say it was hardware and it can be fixed

    Posted from my CrackBerry at wapforums.crackberry.com
    09-15-09 02:44 AM
  3. singularity2006's Avatar
    man... sucks! okay, thanks! I will go look at a repair. Do you have an estimate of how much it will generally cost?
    09-15-09 02:54 AM
  4. puhl64's Avatar
    I posted my experiences with this just yesterday. I have T-Mobile, and they replaced the phone since it was under their standard warranty. Same problem as you, took the same steps, same result - had to get a new phone.

    Take care...
    09-15-09 08:41 AM
  5. mrppinzon's Avatar
    Like 88 $USD, but if u have a warranty use it (:

    Posted from my CrackBerry at wapforums.crackberry.com
    09-15-09 11:17 AM
  6. singularity2006's Avatar
    snaps... bought this phone last Dec. as an unlocked phone from a t-mo employee who got one through her work... no warranty here.

    anyone might know of a cheaper, approx $50 fix? or is it possible for me to fix on my own?
    09-16-09 12:40 AM
  7. mrppinzon's Avatar
    Well go and ask to the store, the price I toll you was they give to me, but here all is more expensive... T.T. If you do let me know how much (:

    Posted from my CrackBerry at wapforums.crackberry.com
    09-16-09 01:58 AM
  8. Blade_27's Avatar
    09-16-09 09:14 PM
  9. kyleresq's Avatar
    Happened to me too and I ended up with a new BB. Warranty swap.
    09-17-09 03:40 PM
  10. Blade_27's Avatar
    Just got off the phone with tech support. After pulling the battery and reinstalling the os I'm gonna be getting my 3rd {2nd refurbished} 8220. Other then my 3rd pin while still into my 1st BB model & my Invisible Shield I'd say the whole ordeal still sucks!
    09-19-09 01:50 AM
  11. jhill's Avatar
    yep, happened to me too, got warranty replacement (even though I bought the phone on ebay... :-)

    try calling tmo and see if they will send you a new one!
    09-21-09 09:37 PM
  12. bmxrideher's Avatar
    jhill, What did you say to T-Mobile to get a new phone? I bought mine on craigslist
    09-22-09 03:18 PM
  13. Blade_27's Avatar
    Cheese & Rice! I just pulled the replacement out of the box & it turned itself off 6-7 times in the hour & half I was trying to set it up, twice while on the phone with tech. My 4th bb flip within a year should be arriving sometime after next week. I gotta send the defective replacement for my non-working Bluetooth back before I can get the hopefully working replacement for my non-working Bluetooth.
    09-22-09 09:03 PM
  14. singularity2006's Avatar
    I just took it to a local shop here that specializes in phone repairs and sales...

    BAM... $200 to replace the mobo. I got this off Craigslist so no warranty. I guess it's time to shop for a new wired headset.
    09-25-09 09:23 PM
  15. mrppinzon's Avatar
    I just took it to a local shop here that specializes in phone repairs and sales...

    BAM... $200 to replace the mobo. I got this off Craigslist so no warranty. I guess it's time to shop for a new wired headset.
    wow 200$?? that was more than i was expecting... i decide to let my bluetooth dead for now because i don't realy use it to much (: but someday i will make it live again hahah
    09-26-09 02:25 PM
  16. mrppinzon's Avatar
    My Bluetooth were fixed! For a while D: was exiting and sad at the same time lol , I was making diner when I put my phone on the stove (electric) what I didn't saw was it was hot, pickup it like 10 seconds later.. My phone was realy hot D: so I put it on the feezer.. Later I take it out and see if works fine, big surprise!! Bluetooth on!! But like 20 minutes after that... He die again T.T

    Posted from my CrackBerry at wapforums.crackberry.com
    09-28-09 03:07 PM
  17. Blade_27's Avatar
    Well I finally got a working device in the mail yesterday. Bluetooth is on & the device has not shut itself off... yet. Strange thing on install, after initial start network, wi-fi & Bluetooth were already on. I've never loaded a bb without after having to manually go in and turn on each connection.
    10-16-09 10:27 PM
  18. NorrisCell's Avatar
    I just took it to a local shop here that specializes in phone repairs and sales...

    BAM... $200 to replace the mobo. I got this off Craigslist so no warranty. I guess it's time to shop for a new wired headset.
    If you choose to sell it and go with something different entirely, I'd be interested in buying it. I have no use for BT, so it would be a perfect phone for me.
    10-20-09 02:04 AM
  19. singularity2006's Avatar
    ah, tragic. I have actually already sold the phone.
    10-20-09 02:09 AM
  20. fsb's Avatar
    Chalk up another one that the Bluetooth doesn't work. I spent most of yesterday talking to T Mobile and RIM about this. Now they want me to uninstall everything and reinstall it. I haven't used the Bluetooth since I upgraded to .180 and I tried to enable it with no sucess.
    10-22-09 07:15 AM
LINK TO POST COPIED TO CLIPBOARD