1. capone24's Avatar
    so i was at walmart and picked up an 8gig card. i formatted it and transfered everything from the previous card. everything worked fine and a few days later a message popped up saying that the memory card could not be read, and that the card needed to be reformatted. now it wont read on the computer or the phone. everytime the card gets inserted anywhere it says it needs to be formatted.... what do i do, i cant loose whats on there!
    06-20-10 05:02 PM
  2. mcdanielnc89's Avatar
    I keep getting this with my 16gb card.....
    06-20-10 05:09 PM
  3. FF22's Avatar
    It could be a bad card. Was it just "anybrand" or a name brand item?

    When you say it won't read on the computer, while in the phone or a separate card reader? If it won't read outside of the phone you may have a problem. There are programs that can forcefully read some cards and recover "erased" files but you'd have to hope that the card is not really GONE.
    06-20-10 06:27 PM
  4. mcdanielnc89's Avatar
    Mine's a SanDisk. My 2Gb one was a SanDisk as well and workd fine.
    06-20-10 06:41 PM
  5. albee 1's Avatar
    You sure you needed to format? I bought an 8gig and just put it in and it worked fine.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-20-10 07:26 PM
  6. mcdanielnc89's Avatar
    Mine worked fine. Then it kwpt saying needs repaired. Does it if I take it out of the BB or unplug it from usb.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-20-10 07:31 PM