1. dmackerson's Avatar
    my 8320 keyboard and all buttons will not work.the track will move and you can highlight things but you cant select. its a tmoblie phone i'm using on att. i have 4.5 on it.the keyboard will light up and the computer can recognize it fine just cant use the buttons. does os effect this should i downgrade and where a can i get older os to download. i have had it a few days worked fine at first. any help will be much appreciated thanks
    03-07-09 10:57 PM
  2. Tremortality's Avatar
    Any water damage at all to the phone. Have you tried doing a battery pull with the phone on? You are wondering about the OS - did you do a recent upgrade and this started to happen?
    03-07-09 11:02 PM
  3. dmackerson's Avatar
    no water damage. i just got the phone and upgraded it worked fine for about a day then it started doing this. i've wiped it and reloaded 4.5 twice and nothing works. and i have done a battery pull. nothing.
    03-07-09 11:10 PM
  4. dmackerson's Avatar
    does it matter if its att blackberry software or tmobile?
    03-07-09 11:11 PM
  5. xliderider's Avatar
    Sounds a lot like water damage, but since it's new just take it back for another phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-07-09 11:12 PM
  6. dmackerson's Avatar
    definitely not water damage. is software a issue or should i just consider it hardware failure. this phone is new but not returnable is it fixable any ideas? thanks
    03-07-09 11:16 PM
  7. xliderider's Avatar
    If it's under 12 mos old it falls under RIM's warranty.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-07-09 11:20 PM
  8. dmackerson's Avatar
    i know this sounds stupid but where can i check if the warranty is good for this phone
    03-07-09 11:24 PM
  9. dmackerson's Avatar
    anybody have any idea how if i could have some replace the keyboard components and how much that might cost
    03-08-09 09:21 AM
  10. xliderider's Avatar
    Even if you replace the keyboard, the problem sounds like it's with the circuits/switches on the main board that respond to the keyboard and trackball presses.
    03-08-09 02:01 PM
  11. laker072's Avatar
    Had a simliar prob - bought a refurb from Ebay to replace....
    03-08-09 04:38 PM
  12. dmackerson's Avatar
    thanks everyone for the help
    03-09-09 04:31 PM
  13. jh5637's Avatar
    My 8320 just did the same...would come on, but buttons and trackball presses would do nothing. Tmobile store guys were no help. Water damage sticker is still white. Started doing this from one day to the next. I just ended up getting the 8900. Now I need to know how to get all my old data, i.e. password list, contacts, memo pad data, etc. Any suggestions?
    03-29-09 01:41 AM
LINK TO POST COPIED TO CLIPBOARD