1. jinxednuance's Avatar
    Hello everyone,

    I recently moved to Koodo after having been with TELUS, Rogers and Fido.

    With all the carriers (except Koodo) whenever I would travel overseas, I would just connect with wifi to get BIS activation. I wouldn't even have to turn on network connections.

    Once I got here and connected to wifi, I realized BIS didn't work. I called Koodo and they said you need to have two add-ons one of which costs $2. The guy also said "but you will incur roaming charges since you will be using the data of the country you're in" - I knew this information anyway because I never used roaming data, I Would always connect to wifi.

    So even after subscribing to those add-ons, and turning wifi on, I am still not connected to BIS. Does anyone have any clue why?! This service worked perfectly fine with previous providers and I never paid anything for data roaming.

    Any input would be appreciated.

    Thanks!
    12-28-12 12:06 AM
  2. Crowezine's Avatar
    I've had similar problems before here in the UK, and I ended up just removing my sim, and going to one of the most popular sim's used for smartphones. Which here is O2. And that sorted it. Just go to the place with the best customer service, and they will help you through it.
    01-04-13 08:45 AM
  3. lnichols's Avatar
    Hello everyone,

    I recently moved to Koodo after having been with TELUS, Rogers and Fido.

    With all the carriers (except Koodo) whenever I would travel overseas, I would just connect with wifi to get BIS activation. I wouldn't even have to turn on network connections.

    Once I got here and connected to wifi, I realized BIS didn't work. I called Koodo and they said you need to have two add-ons one of which costs $2. The guy also said "but you will incur roaming charges since you will be using the data of the country you're in" - I knew this information anyway because I never used roaming data, I Would always connect to wifi.

    So even after subscribing to those add-ons, and turning wifi on, I am still not connected to BIS. Does anyone have any clue why?! This service worked perfectly fine with previous providers and I never paid anything for data roaming.

    Any input would be appreciated.

    Thanks!
    Definitely carrier doing something to block the device from working and the "add-ons" for $2 sounds like complete BS to me.
    01-04-13 09:13 AM

Similar Threads

  1. Replies: 0
    Last Post: 07-20-09, 08:36 PM
  2. 8330 email issues with BIS and Outlook; will not reconcile!
    By tommyw in forum BlackBerry Curve Series
    Replies: 0
    Last Post: 07-20-09, 08:36 PM
  3. Issues with BIS + Outlook/Exchange OWA
    By alect in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 05-28-09, 09:26 PM
  4. Gmail issues with BIS...(tried search)
    By rbdynamics in forum BlackBerry Storm Series
    Replies: 13
    Last Post: 03-09-09, 11:40 AM
  5. Any issues with BIS lately?
    By mitch23 in forum General Carrier Discussion
    Replies: 5
    Last Post: 02-25-09, 01:31 AM
LINK TO POST COPIED TO CLIPBOARD