1. michiberry11's Avatar
    It worked fine the first day but ever since its like way off... and there are no settings really for the app I was wondering if anyone has had this problem and if there is a way to fix it my friend has the bb 9700 and his works fine but mine is way off in locations

    i have the bold 9000 btw
    04-15-10 06:51 AM
  2. sin1134's Avatar
    i run it on blackberry tour and have probs like that as well and its kind of a new app still in the tweaking phases, alot of times i completely log out and log in again and that will fix things but only somtimes. i check in from ground zero alot and it tells me in too far away....i have the newest version for bb pm for link maybe it will help im running 1.7.6
    04-16-10 10:24 PM
  3. BlitzedATL's Avatar
    I read some other posts about this (I don't use foursquare). It seems like people were 'cheating' by checking into places they weren't at so foursquare put in some 'fix' to stop this and now a lot of people are reporting the same thing you are. Seems like they need to do some more tweaking.

    If your friend hasn't updated to the newer version that could explain why his is working better. Since you just downloaded you have the 'fixed' one.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-16-10 10:39 PM
  4. rlindydiane's Avatar
    Occasionally after I do a battery pull and I attempt to log into Foursquare it will start like normal but when I go to check in it'll tell me "Can't find your current location so we pulled up your last one." So what I do is exit out completely, go into "maps" and "start gps navigation." Once it starts working stop it then go back into Foursquare to "check in." It has yet NOT to work for me. The app then finds my location everytime.
    bbangelbaby likes this.
    06-05-10 12:30 AM
  5. bilmaga's Avatar
    I have the same issues as well. I can be at the other end of the city and it will still show my last known location. I try manually check in and it says I'm too far away even though I'm inside the place. Pretty frustrating sometimes

    Posted from my CrackBerry at wapforums.crackberry.com
    06-05-10 08:58 AM
  6. ontariopunk's Avatar
    Yup, Im having the same problems as well. It keeps saying location not found. I've tried it all over different parts of the city. And nothing! Even searching shows up with nothing.
    09-07-11 01:09 PM
  7. tedesco's Avatar
    Same here on my 9900. I did not have this problem with my bold 9000. Suddenly I need to start maps before foursquare can read my GPS info. Why is this happening? I have pretty much stopped using foursquare because it's a bit of a pain.

    Maps is slow to find my location also. Seriously, if a check-in is going to take more than 30 seconds... those imaginary badges just aren't worth it.

    Blackberry and Foursqaure (and quite possibly service provider) please get together to fix this issue.
    10-27-11 07:04 PM