1. boeingrules's Avatar
    My Z10 is riddled with so many problems I can't even write a list of them without my phone rebooting or running out of battery. But I don't want this to sound like a rant, and I actually REALLY need to fix these issues, so I'm just going to ask for help on the two biggest ones. I've tried digging around in the forums a bit, but I couldn't find a solution, so here I am... I'm not sure if this is the right place to post this, so please move this to the correct forum if needed.

    1. My phone won't connect to wi-fi
    This is huge. I hope this one has an easy fix. When I go to settings, I turn the wi-fi on, and I select a network (although sometimes my BB does it for me). Then, under the wi-fi name, there is a green 'connected' message as well as another connected section that appears at the top of the page. For now, it seems like everything's working fine and that everyone will live happily ever after. But then, I swipe up, go to my browser, and try to load a video. I doesn't load. Instead, it gives me an error message, usually saying I have no connection (it changes sometimes). I go back to my home screen and notice that there is no wi-fi symbol, not even an empty one. Theres just that big capital 'E' (I have terrible reception at my house). But when I go back to settings, it says that I am connected! Am so confused. I tried joining different networks, resetting my phone, nothing I try seems to be working.

    2. BB Link doesn't work
    Very important one for me. Now I have no way to transfer music and photos between my laptop and my BB, which kills me. Of course, I have bluetooth, but that's painful to use on my Z10 because for some reason I can only transfer a few files at a time or else the transfer won't even start. I had used it before, and even then it was super laggy and sometimes would just randomly drop the transfer, which is why I only have albums up to 'D' on my phone. When I try to open BB Link manually on my computer, it gives me an error saying 'BB Link is already active and running'. Well, it's not, because it closes down right after I close the message.

    I'm not too concerned because I suspect there are easy and quick fixes for both of these, and they are probably painfully obvious. If you can help, please post quickly, I'd really appreciate it. Thanks in advance!
    02-11-14 03:57 AM
  2. silversmith75's Avatar
    try deleting the the connection, and start over again by connecting to network.. so when you go into wifi hold on the connection till menu appears from the side and delete it.. then either reboot. and try or just try to reconnect to network

    the link i am not sure. what about it is not working? i guess with not being able to connect to your home network you would not be able to sync wirelessly... maybe see if fixing wifi solves your other issue.. have you tried connecting cable to computer and devise.. if soo..make sure link is turned off then connect your phone..

    hope that helps..
    02-11-14 04:06 AM
  3. boeingrules's Avatar
    Thanks I'll try the wi-fi tips.

    BlackBerry Link won't even open. It says that it is already running, then quits after that. I did this by connecting with a cable.

    Thanks for the help.

    Posted via CB10
    02-11-14 04:10 AM
  4. silversmith75's Avatar
    oh go into task manager, and under processes stop any thing that says blackberry link in it...
    if that doesn't work uninstall it and redownload it and reinstall..

    and if you are having a lot of problems with your phone once you get link working again, i would wipe and reload the os on your phone...
    02-11-14 04:18 AM
  5. rizdragon's Avatar
    kindly state the OS of your device as well as the device model. additionally state which pc/laptop you are trying bb Link on, the operating system of the pc/laptop and the version of bb Link.

    make sure you have eveything updated and latest.

    reinstall bb Link, reboot pc/laptop and device (your phone)

    for me link works off and on... the only solution i have found is to reboot my pc which is running Win XP Professional SP3.

    for WIFI, make sure your wifi router/modem has been enabled to connect the number of devices you are trying to connect. i've limited my wifi devices to only 4 and it's filtered only to allow the mac addresses listed. check your notifications to see if you aren't getting a notification of limited wifi connection.

    kindly also list the things which you have tried already so that members here can help/guide you better.

    thank you
    02-11-14 06:15 AM
  6. Rello's Avatar
    Yes like the poster above says, tell us what OS u are running please


    Posted via CB10
    02-11-14 09:07 AM
  7. silversmith75's Avatar
    did you solve the problem?
    02-12-14 03:35 AM
  8. tomcat23's Avatar
    For Wifi problems check your router settings. If it says connected but there is no wifi signal on the device home screen that usually means it's connected to the router but there is no access to the net.
    This would happen if your router is not passing on the DNS server address automatically to the Z10.
    Two things can be done about this :
    1) Check your router settings and ensure that your ISP's DNS address is there where it should be for the router to broadcast the same.

    2) the other way is to configure the wifi manually on your Z10. There assign a manual IP address, input the DNS address of you ISP and assign a subnet mask.
    This should solve the wifi problem. This is not a device issue, more a network issue.


    Posted via CB10
    02-12-14 04:42 AM

Similar Threads

  1. Z10 Rebooting by itself
    By CorneB in forum BlackBerry Z10
    Replies: 13
    Last Post: 07-15-14, 09:35 PM
  2. Battery problems?
    By campbecw in forum BlackBerry Z30
    Replies: 5
    Last Post: 02-21-14, 03:06 PM
  3. Z10 bluetooth not connecting
    By tgrsnpr in forum BlackBerry Z10
    Replies: 2
    Last Post: 02-11-14, 11:52 AM
  4. Z10 for sale on eBay
    By silversmith75 in forum BlackBerry Z10
    Replies: 4
    Last Post: 02-11-14, 11:12 AM
  5. Replies: 2
    Last Post: 02-11-14, 08:19 AM
LINK TO POST COPIED TO CLIPBOARD