1. sahilp17's Avatar
    Hey guys,

    Im sure this has been answered before but im freaking out so much right now in the middle of final exams and everything because My Z10 has decided to ditch me! It hasn't been turning on all day. Here's the diagnosis, I can hit the lock button and the only thing that will happen is there will be the red light for maybe 2 minutes and it will disappear. I can continue to do this and the same thing will happen with the red light. I tried the battery pull, same thing with the red light. I tried to connect it to the pc hoping it will recognize it and i can do the software reload, but the PC doesn't recognize the z10. Please please someone help me ill forever be indebted. I also tried the volume keys together for about 30 seconds. I know it looks like it's bricked but if someone out there has a magical solution please share. I bought it July 2013 at a Costco for Verizon. So did it automatically come with 1yr warrantee or something? Also, the phone was not currently running on a leak, it was currently on the latest official 10.2.1 from verizon...
    05-01-14 05:33 PM
  2. anon(3987448)'s Avatar
    Have you tried charging the phone,

    Z10STL100-3/10.2.1.2234 on Bell with Unlimited Data
    05-01-14 05:38 PM
  3. sahilp17's Avatar
    Yes, yes I have
    05-01-14 05:40 PM
  4. dehdude's Avatar
    I would consider charging it for a significant amount of time. I have had similar symptoms once and it eventually came back.

    Posted via CB10
    05-01-14 05:44 PM
  5. anon(3987448)'s Avatar
    Take the battery out, leave it out

    Put the charger in the phone. But use the wall plug not the USB for about 45 min or so,

    Then put the battery in. See what happens

    Z10STL100-3/10.2.1.2234 on Bell with Unlimited Data
    05-01-14 05:44 PM
  6. Andy_bb_king's Avatar
    Try another battery ?

    Posted via CB10
    05-01-14 05:48 PM
  7. trinichindian's Avatar
    With the battery out, connect it to the pc and see if link detects it.

    Zwiped from my Zed
    05-01-14 06:22 PM
  8. sahilp17's Avatar
    Im going to try all of these things within 24 hours. I surely appreciate you guys giving feedback. For now my samsung slider messaging phone will have to do...
    05-01-14 06:39 PM
  9. Alain_Manjgo's Avatar
    Try rebooting the os on blackberry link I had a problem were the light would pop up and nothing else then I rebooted the os of BlackBerry Link hope this helps

    Posted via CB10
    05-01-14 08:08 PM
  10. xiaosulpum's Avatar
    Remove the battery, put the cable on and plug it in your computer. Wait for couple of minutes and see if the computer will recognize your phone.
    05-02-14 02:14 PM
  11. sahilp17's Avatar
    I have tried and exhausted all of your ideas, without any luck. Removed the battery and plugged it into the computer and still no response but of course the red light is there. Just going with the warranty now
    05-04-14 01:23 AM
  12. g33kphr33k's Avatar
    Mine did that and needed replacing.

    I think I toasted it in my pocket, plus fairly tight jeans so when I sat, it flexed slightly to much. The Z10 runs hot anyway so the factor I am thinking is overheating more than damage from flexing as there was not outer damage.

    Tl;dr Warranty swap is probably the best idea.

    Z10 until Z30
    05-04-14 01:47 AM
  13. dustmalik's Avatar
    What variant of Z10 is it? Is it STL 100-1, 2, 3 or 4?
    Anyway, get an autoloader from the leaks forum and install it. That should solve it. I recommend this 10.2.1.2947 OS for all except STL100-1

    Posted via CB10 using my Gorgeous Z10
    05-04-14 05:04 AM
  14. ronfc's Avatar
    I wonder if the OP sorted this out..

    Cave, cave, moderator videt
    05-04-14 05:19 AM
  15. nhanken's Avatar
    I have tried and exhausted all of your ideas, without any luck. Removed the battery and plugged it into the computer and still no response but of course the red light is there. Just going with the warranty now
    Hi Sahilp, I think you're having a similar problem as of one my friends' Z10 where the phone didn't turn on one day and doing a battery pull, leaving the battery out for an extended period of time, plugging it to the computer without the battery... etc etc... but nothing worked. Installing leaks didn't help and the device "suddenly disappeared" during the very last moment of the installation. Another friend who knows how to diagnose phones told me that the Z10 cannot be fixed because one of the cores isn't working anymore. What he meant is that it cannot run the OS with one of the cores dead unless you replace that defective core, which average consumers like us wouldn't be able to buy the part and do.
    So you might have to bring it back to Costco for warranty.


    Posted via CB10
    05-04-14 05:24 AM
  16. knighty2112's Avatar
    Have you tried stack charging your phone? Watch the video link below and it explains what stack charging is. I know the video is for the PlayBook, but the Z10 battery charges up the same way, so if the voltage of the battery is so low then the only way to get it to a level to start booting up the OS on the phone is to stack charge it.

    Good luck. Hope you get your phone working again.



    Careful! Z10 in action!
    bambinoitaliano likes this.
    05-04-14 06:12 AM
  17. sahilp17's Avatar
    Appreciated all the responses. To those who specifically said to try autoloaders to reload the device software, the computer actually CANT recognize the phone, it is bricked so those aren't options. I'll be contacting both Verizon and Costco once my Final Exams are over on Thursday.
    05-04-14 05:24 PM
  18. bambinoitaliano's Avatar
    Have you tried stack charging your phone? Watch the video link below and it explains what stack charging is. I know the video is for the PlayBook, but the Z10 battery charges up the same way, so if the voltage of the battery is so low then the only way to get it to a level to start booting up the OS on the phone is to stack charge it.

    Good luck. Hope you get your phone working again.



    Careful! Z10 in action!
    It sounds quite similar to a playbook issue.

    Posted via CB10
    05-04-14 05:36 PM
  19. trinichindian's Avatar
    Hi Sahilp, I think you're having a similar problem as of one my friends' Z10 where the phone didn't turn on one day and doing a battery pull, leaving the battery out for an extended period of time, plugging it to the computer without the battery... etc etc... but nothing worked. Installing leaks didn't help and the device "suddenly disappeared" during the very last moment of the installation. Another friend who knows how to diagnose phones told me that the Z10 cannot be fixed because one of the cores isn't working anymore. What he meant is that it cannot run the OS with one of the cores dead unless you replace that defective core, which average consumers like us wouldn't be able to buy the part and do.
    So you might have to bring it back to Costco for warranty.


    Posted via CB10
    My this is what happens to mine last year, but warranty allowed me to get a replacement from my provider.

    I tried everything in the book but that darn red light would just blink at me..

    Zwiped from my Zed
    05-04-14 06:42 PM

Similar Threads

  1. Z10 Faulty Audio Jack - Under Warranty - Likelihood of Upgrade?
    By PineappleOranges in forum General Carrier Discussion
    Replies: 3
    Last Post: 05-23-14, 10:20 AM
  2. Replies: 31
    Last Post: 05-04-14, 10:01 AM
  3. Replacing Z10 charging port?
    By shamul haq in forum BlackBerry Z10
    Replies: 3
    Last Post: 05-01-14, 11:21 PM
  4. Preparing Z10 for Sale help
    By carwacster in forum BlackBerry Z10
    Replies: 3
    Last Post: 05-01-14, 04:37 PM
  5. BlackBerry Z10 Repair Problem
    By thomas90453 in forum BlackBerry Z10
    Replies: 1
    Last Post: 05-01-14, 12:48 PM
LINK TO POST COPIED TO CLIPBOARD