1. sc0rpion's Avatar
    Ok, after reading some posts about people having trouble using WIFI only with the phone services turned off, I decided to figure it out, and I did. This may be known by many but for those who dont read on.

    If you are turning off your phone's services by going through Options/Mobile Network, and turning the Data Services to off, your doing it wrong. If you do that here, it kills everything for browsing, 3G or WIFI.


    To do it the right way, go to your Blackberry home page, and there should be a icon that says Manage Connections. Once you get in there you will see 3 boxes. First one for Mobile Network, seconds for WiFI, and third for bluetooth. Uncheck the box for Mobile Network and leave the WIFI one checked.

    Now you are surfing WIFI only. No 3G. It even removes the symbol from the top of the phone. Test it out, hope it helps those who are curious and frustrated.


    **Blackberry 4 Life!**
    10-31-09 04:02 AM
  2. res6jya6's Avatar
    Alot of it has to do with the WiFi icon itself... even with the WiFi on, and the Cellular Signal off, they were only able to surf the internet. Yesterday, I was having the same issue... no BBM/YahooMSGR/AOL/Pandora/Push Email... and the icon was grey. But today, the icon is white and I am able to get my email, use pandora, use the messenger programs... it just miraculously fixed itself, I suppose!
    10-31-09 04:06 AM
  3. Mrcapo's Avatar
    That kind of works but then you can't receive any calls or texts until putting it back?
    10-31-09 04:09 AM
  4. zeiroe's Avatar
    ... you know ... I smell the possibility of a new app or feature built in to an existing app (cough ... quick launch) that will automatically enable wifi and disable the mobile network and vice-versa with one button
    10-31-09 04:11 AM
  5. 1812dave's Avatar
    Ok, after reading some posts about people having trouble using WIFI only with the phone services turned off, I decided to figure it out, and I did. This may be known by many but for those who dont read on.

    If you are turning off your phone's services by going through Options/Mobile Network, and turning the Data Services to off, your doing it wrong. If you do that here, it kills everything for browsing, 3G or WIFI.


    To do it the right way, go to your Blackberry home page, and there should be a icon that says Manage Connections. Once you get in there you will see 3 boxes. First one for Mobile Network, seconds for WiFI, and third for bluetooth. Uncheck the box for Mobile Network and leave the WIFI one checked.

    Now you are surfing WIFI only. No 3G. It even removes the symbol from the top of the phone. Test it out, hope it helps those who are curious and frustrated.


    **Blackberry 4 Life!**
    I have gone into Manage connections to turn off mobile network.

    I have no router name at the top of my screen, EVER.

    I can't use the browser if mobile net is off.

    the wifi is GRAY.

    in the wifi options screens it says "not connected"

    I am at a loss to get wifi connectivity


    I'm going to return the phones tomorrow to verizon. enough of this nonsense. this is beyond pathetic. I've wasted the last 6 hours of my life dealing with this phone. no wifi and no maps.
    10-31-09 04:17 AM
  6. olta777's Avatar
    Like I mentioned in the other thread, you got to register host routing table. Wifi has been fixed. I have been using it all day today (with data connection off).

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-09 04:38 AM
  7. sc0rpion's Avatar
    to re-register your phone go to options, advanced options, host routing table, then click your blackberry button and select register now. After you do that, retry setting up your wifi and make sure you are putting in your correct passcode if you have one for your wifi network. Also when you do the WIFI setup wizard, does it show you your router at all? Your wifi on your phone is grey'd because it's not connected to any wifi spots. Double check those things and im sure you will have success. Like olta said, i think they have fixed the issue and re registering your phone will fix any kinks it may have.
    10-31-09 04:57 AM
  8. 1812dave's Avatar
    to re-register your phone go to options, advanced options, host routing table, then click your blackberry button and select register now. After you do that, retry setting up your wifi and make sure you are putting in your correct passcode if you have one for your wifi network. Also when you do the WIFI setup wizard, does it show you your router at all? Your wifi on your phone is grey'd because it's not connected to any wifi spots. Double check those things and im sure you will have success. Like olta said, i think they have fixed the issue and re registering your phone will fix any kinks it may have.
    I've gone into the diagnostics screen for wifi and it keeps trying to connect but fails. It has the router signal strength, password, etc, but Status is "Device failed to associate with AP..."

    I just deleted the profile and set it up again, I get "success" but still no connection to the network.
    10-31-09 05:23 AM
  9. TheHeartlessHero's Avatar
    The wifi signal can be greyed out but connected to a router if you are not connected to BIS/BES. If so, u can really only browse the internet with that kind of connection. RIM pushed a fix for that yesterday though.
    10-31-09 05:39 AM
  10. 1812dave's Avatar
    The wifi signal can be greyed out but connected to a router if you are not connected to BIS/BES. If so, u can really only browse the internet with that kind of connection. RIM pushed a fix for that yesterday though.

    IF i turn off the "mobile network" I can't browse the web.

    also, others mention I should see router name at top of home screen. never seen it.
    10-31-09 05:50 AM
  11. 1812dave's Avatar
    on a happier note, I had no trouble pairing with a Jabra SP700 car BT device!
    10-31-09 05:50 AM
  12. TheHeartlessHero's Avatar
    Yea, I have read your posts, I was merely correcting the other user that greyed out means totally unfunctional, you would be best creating your own thread or using the other one with all the questions/answers, that way people can see what you've tried and all.
    10-31-09 05:58 AM
  13. MikeAllard's Avatar
    You can get the connections screen faster (one touch) but pressing the upper right hand corner wher it says 3G on the main screen. You can turn on/off Mobile netowrk, Wifi and Bluetooth, set up WiFi netowrks, etc.
    10-31-09 07:29 AM
LINK TO POST COPIED TO CLIPBOARD